NetGear AirCard 340u


#1

I am trying to get a NetGear AirCard 340u to work on DragonBoard running Linaro currently with Linux kernel 4.4.9. I did a dist-upgrade and rebooted in case a new kernel was installed. The Netgear documentation, http://kb.netgear.com/app/answers/detail/a_id/26983, says that their drivers are only supported under kernel versions 2.6 to 3.5.0.23. I tried to compile them as they instruct but got errors.

Further searching yielded these leads:

It looks like I can go about this a few different ways: downgrade the kernel to 3.5.0.23 (not preferred), install the qcserial and qmi_wwan modules, or install the sierra and sierra_net modules. The qmi_wwan and sierra_net modules are not available in Linaro's 4.4.9 build but are available in the 3.16.0 and 4.7.0 builds as well as in the 4.4.9 kernel source tree.

I found one mention of qmi_wwan in the 96board github page: https://github.com/96boards/wilink8-wlan_wl18xx/commit/ba6de0f5304ccdc45ae260e7e0feb6e0ef2dd558.

I tried forcing the device to use the qcserial and sierra drivers by modifying their new_id files to 1199 9051, (not at the same time). 1199 9051 are the vendor and product ids returned by lsusb for this device. It would show up as /dev/ttyUSB2 and /dev/ttyUSB3 when associated with qcserial, but would throw errors.

So how do I go about getting those modules? Is it possible to safely upgrade to linux kernel 4.7.0?


#2

I was able to get the device to work on my Asus Chromebook Flip C100PA running Arch Linux using the cdc_mbim kernel module, which is not available in the current Linaro Debian build. This module was associated with the device automatically. I followed the instuctions that I found here. apt-file search cdc_mbim returned linux-image-3.16 and linux-image-4.7.


#3

Sounds like you might have to be recompiling the kernel.

The instructions on how to do this can be a bit hidden. They are part of the release notes and are shown at the bottom of the download pages:
http://builds.96boards.org/releases/dragonboard410c/linaro/debian/16.09/

You’re also welcome to file a bug report asking for the module to be enabled by default (https://bugs.96boards.org ) although that will take a long time to flow through the system so I’d recommend you building the kernel yourself in the mean time.