Need Helps for Building AOSP 8.1 for Hikey970


#1

Hi!

I’m a beginner who is being struggled in building the AOSP 8.1.

Please help me and let me know how to do it properly…

What I have tried to do is

  1. made the ramdisk.img of hikey960
  2. built the Linux kernel by following the official manual (https://www.96boards.org/documentation/consumer/hikey/hikey970/build/linux-kernel.md.html)
  3. built the AOSP with the hikey970 manifest (https://github.com/96boards-hikey/android-manifest).

I’m stuck in the 3rd stage, the build script makes a following error:

build/make/core/Makefile:28: error: overriding commands for target `out/target/product/hikey970/system/vendor/lib/libc_secshared.so’, previously defined at build/make/core/base_rules.mk:418

The first problem is that I do not know how to handle this error correctly. Only what I know is that it seems a makefile problem. Also, I found that “device/linaro/hikey/hikey970/device-hikey970.mk” and “device/linaro/hikey/ai/Android.mk” refer the same .so file. But I am not sure whether those are directly related or not.

I simply skipped this problem by removing lines that contain ‘libc_secshared.so’ in device-hikey970.mk. It allowed me to successfully build image files.
But the second problem has occurred. The ROM does not work. And, I found out that its filesystem has a problem. The error message is as follows.

[ 6.072654] init: [libfs_mgr]fs_mgr_read_fstab_dt(): failed to read fstab from dt
[ 6.080184] init: Failed to read fstab from device tree
[ 6.085498] init: [libfs_mgr]fs_mgr_read_fstab_default(): failed to find device default fstab

Could you please let me know how to handle the build problem?

Also, if you successfully built AOSP 8.1 for hikey970, could please you give me some hints for building it?

Thanks in advance!!


#2

know issue: also reported at: Lunch hikey970-userdebug does not work

I do not thing removing the lines would help.


#3

I also tried to follow the link(blog.ttcrack.com/index.php/archives/441/), but faced with the same problems.