Multiple usb not working


#1

Hello,

I have installed Android on my board. When i have 2 usb connected (keyboard and mouse), mouse is working but i get “process.com.android.phone has stopped”. When i have a mice alone, it’s working. When i have a mice and a micro-usb to connect to my laptop, mice is not working. Also my android studio does not recognize the device even when i connect the micro-usb alone. What i’m missing? I’m using mac and all settings are set to 0, except the micro-sd (but no sd plugged in)


#2

Am i missing some usb drivers? Please some help ! :slight_smile:


#3

Which image did you install? 16.06? The “process.com.android.phone has stopped” is a known issue seen with specific sets of USB mouse. See https://bugs.96boards.org/show_bug.cgi?id=417 for more details.

Also, you cannot use regular and micro usb at the same time. See http://www.96boards.org/forums/topic/android-on-96boards-faq for details.

For recognizing device on laptop, have you enabled developer mode options?


#4

@vchong, thanks for answering:

I installed the version from here, which seems to be the latest no? Also i tried 2 different mouse.

Ok, thanks for the info.

Yes i enabled developer mode options (hitting seven times the build number and then enabling usb debugging in case i’m missing something here). Then i tried restarting android studio, the device with mini usb only plugged in etc. but nothing worked…


#5

Hello Ernest,
Did you install the drivers?

How is showing the device in your “device manager”?

In case here the link to install the drivers.

http://www.96boards.org/forums/topic/step-by-step-instruction-to-install-adb-usb-driver-on-windows/#gsc.tab=0


#6

@jean-marc:

I’m using mac for development. Currently when i see my device manager on android studio, i have “Connected devices: <none>”. I also installed android-platform-tools with brew, and when i run “adb devices” i get no result.
(All these with the board on, every step to 0, just the mini usb plugged in, and the android version i mentioned above with developer options enabled).


#7

@Ernest
Too bad :smiley:
Try to connect your Android phone and see if you can see it. This will help you to understand where to look at.

Good luck :slight_smile:


#8

In Developer options according to a stackoverflow answer (http://stackoverflow.com/questions/25199660/android-studio-doesnt-recognize-my-device) usb configuration should be on PTP, but i cannot change it from charging with my snapdragon device…


#9

Update: I managed to change after several random click to ptp or mtp, but with no change… (after i disconnected the mouse and reconnected mini usb, when i try to reboot the setting usb configuration goes again back to charging). From the developer options -> select usb configuration.
I’m using Mac, currently no android phone available in the office :slight_smile:


#10

Also from the installation from here: https://github.com/96boards/documentation/wiki/Dragonboard-410c-Installation-Guide-for-Linux-and-Android
i didn’t use the flags “oflag=sync status=noxfer” since they were not recognised… (on a mac always)
I used “sudo dd if=db410c_sd_install_android.img of=/dev/XXX bs=4m” to make it work.


#11

Can you try setting up adb via wifi/tcp? You’ll access to the board’s serial console via an uart/usb cable/adapter? Or configure it via Developer options -> ADB over network if available.


#12

No ADB over network is available… Is there anyone managed to run an android application on a dragonboard ? Lol


#13

Sorry. Not sure why Android Studio is not seeing your device so can only try to give you workarounds. Maybe try building your app as an apk file, transfer it to the board and install it manually? Or try a linux machine to see if it sees the board. If it does, maybe there’s some sort of compatibility issue with your/the mac.


#14

Yes we can run ADB, I do it often with Windows 10. The idea to run it in TCP is excellent vchong.
I can run Android Studio and interface, no problem. Either by USB or WIFI/TCP.

Ernest, I would try to get an Android phone and connect it, just to be sure where the problem is.
From here it will be possible to progress and find a solution.


#15

hello @jmjobin @vchong

the same problem persists when i was connecting my dragonboard 410c having android installed in it .my device is not recognized in command promt .i got message "adb is not recognized as an internal or external command "

thanks in advance!!!


#16

Sorry @ren_snappy but I’m really confused. In the last three hours you’ve posted that:

  • your board doesn’t boot
  • you cannot get the display working
  • when you boot debian you cannot find any bluetooth icon on the
    display
  • that you are running android and cannot get adb to work
  • that you are have trouble following the board recovery instructions
  • that you can’t get audio to work in yocto/openembedded
  • that you can’t get GPS to work in debian
  • that you have hooked up a DHT11 but don’t know how to talk to it

I’m afraid this is simply too much for me to comprehend and your observations are spread across lots of fairly old forum topics which makes it difficult to connect the dots.

Please do not post any further on this topic unless the people you tagged above choose to engage in the conversation with you. In fact I think it is best that, for the next few days, you simply avoid replying to any existing topics.

Instead please start a new topic carefully describing the symptoms your observe and we will try to help.