Microphone is not working


#1

Hi,
I want to record audio via my 410C and I have connected a mic at pin number 6 and 4 at J7. I am using the internal audio recorder app which comes in default android os. I have connected a Bluetooth speaker to listen to microphone recorded audio but it is playing only white noise. Speaker is working fine since it able to play some music files.
I am using this microphone


#2

Which version of android are you running?

It looks like an audio mixer issue, does the following topic help:


#3

Hi,
I am using Android 5.1.1. I have checked many thread and tried to make it working but I could not. Basically, I want to use microphone and I am having three options here 1) Analog mic 2) USB mic and 3) Mic of Bluetooth Headset.

I have tried all of these options but none of these are seems to work to me. My first pref is getting USB mic working otherwise Analog one. Would you share some insight how can I make USB one is working.


#4

Hi @Loic
Somehow I got it working. Analog pic at Inp2 i.e. ADC2 is working fine and HPL & HPR worked like a charm. I had also routed audio to the speaker by adding following lines in

    <ctl name="RX3 MIX1 INP1" value="RX1" />
    <ctl name="SPK DAC Switch" value="1" />

But I can not control audio volume at the speaker. Either it is playing in full volume or it is being mute. Moreover, I am having two problems.

  1. How can I control speaker volume?
  2. How can I increase the gain of the mic? It is working fine but I would like to increase its gain a little more.

#5

I have been trying to make the Bluetooth mic work (HSP or HFP) with the Linaro downloaded from the site (boot and rootfs). However, each time I try to switch to HSP, X11 dies (I suppose the error is the known “refused to switch”). Has anyone succeeded using the Bluetooth mic with db410c / Linaro?
Thanks