Meaning of MultiMedia1 messages with USB camera


#1

Hi. If I have a USB camera connected to the Dragonboard, then on boot up I see a bunch of MultiMedia1: ASoC: no backend DAIs enabled for MultiMedia1 messages in the log. They seem to happen right after the USB camera is probed:
[ 41.314899] usb 3-1.2: reset high-speed USB device number 4 using xhci-hcd
[ 41.813024] MultiMedia1: ASoC: no backend DAIs enabled for MultiMedia1
[ 41.813120] MultiMedia1: ASoC: no backend DAIs enabled for MultiMedia1
[ 41.819218] MultiMedia1: ASoC: no backend DAIs enabled for MultiMedia1
[ 41.825744] MultiMedia1: ASoC: no backend DAIs enabled for MultiMedia1
[ 41.832202] MultiMedia1: ASoC: no backend DAIs enabled for MultiMedia1
[ 41.844376] MultiMedia1: ASoC: no backend DAIs enabled for MultiMedia1
[ 41.845822] MultiMedia1: ASoC: no backend DAIs enabled for MultiMedia1
[ 41.852284] MultiMedia1: ASoC: no backend DAIs enabled for MultiMedia1
[ 41.858623] MultiMedia1: ASoC: no backend DAIs enabled for MultiMedia1
[ 41.865154] MultiMedia1: ASoC: no backend DAIs enabled for MultiMedia1
[ 41.873319] MultiMedia1: ASoC: no backend DAIs enabled for MultiMedia1

They print for a couple of seconds and then stop. Does anyone know the meaning of the messages?
Also if I plug in the USB camera after the dragonboard is up and running then I do not see these messages.

Thanks,
kimbo


#2

This is related to audio. Here I understand there is no audio interface to ‘play’ sound.
DAI is for SoC Digital Audio Interface.


#3

Hi Loic,
We are not using any audio. Could I just disable sound in the device tree and then I won’t see the messages? Like this:
&sound {
compatible = “qcom,apq8096-sndcard”;
status = “disabled”;

Thanks,
Kim


#4

Yes, you can also disable CONFIG_SND in your kernel config.


#5

Perfect! Thank you so much :slight_smile: