"make boot image" failed


#1

I did as for this instructions;

Kernel src tree comes from Android BSP, it was built well.

During making boot image,
I’ve got “No valid dtbs found” at create dt.img step.

Some other question says ‘fdtget’ should be installed before.
I did, but same error until now.

Any Ideas?

mipsan


#2

I haven’t tried the skales tools with 3.10 android kernel. they might not work… the tools were designed to be used with recent/mainline kernel. it is possible that the 3.10 DTS files do not contain enough information for dtbtool to work properly.

maybe someone can investigate further… or you can have a look at the Android build system (from Android CAF manifest) to understand how they build their boot image, they don’t use skales.

btw, your issue is not related to fdtget.


#3

Thanks for your advice.

I have to dig Android BSP.


#4

To rebuild the Android image, look at this page
Getting Started and find the “Software build and installation guide” and the “Android Release Notes”. Follow the instructions in the build and installation guide to build the version referred to in the release notes.

Hope this helps.

Full Disclosure: I am an employee of Qualcomm Canada, any opinions I might have expressed may not reflect the opinions of my employer.


#5

Thanks @ljking,

I’ll find to read it carefully.

mipsan