Locale-base-en-us error on Yocto hikey build with meta-networking


#1

I’ve been working on understanding more about the build process for the Hikey using both Yocto and the basic OpenEmbedded outlay laid out in the documentation. In both cases when I try to build an image that includes meta-networking (for ifconfig and a bunch of other nifty tools), I keep getting the following error:

ERROR: rpb-console-image-1.0-r0 do_rootfs: locale-base-en-us not found in the feeds (hikey aarch64 noarch any all) in /home/alnicoll/yocto/hikey/tmp-glibc/deploy/rpm.
ERROR: rpb-console-image-1.0-r0 do_rootfs: This is often caused by an empty package declared in a recipe’s PACKAGES variable. (Empty packages are not constructed unless ALLOW_EMPTY_<pkg> = ‘1’ is used.)
ERROR: rpb-console-image-1.0-r0 do_rootfs: Function failed: do_rootfs
ERROR: Logfile of failure stored in: /home/alnicoll/yocto/hikey/tmp-glibc/work/hikey-linaro-linux/rpb-console-image/1.0-r0/temp/log.do_rootfs.23453
ERROR: Task (/home/alnicoll/yocto/poky/meta-rpb/recipes-samples/images/rpb-console-image.bb:do_rootfs) failed with exit code ‘1’

I’ve tried manually adding the package locale-base-en-us, updating the eglibc recipe, adding GLIBC_GENERATE_LOCALES, ALLOW_EMPTY_local_base_en_us, and other patches, but none of those worked. I’ve tried chasing the dependencies to see where the dependency comes in, but my OpenEmbedded skills are not quite where they need to be yet. Has anyone run into this before, and if so, how did you diagnose / fix it?

Thanks!

-Alex