Linux boot errors


#1

I have flashed flashed the following images from here http://snapshots.linaro.org/reference-platform/embedded/morty/hikey960/latest/rpb-wayland/ with success messages

sudo fastboot flash boot boot-.img
sudo fastboot flash system rpb-console-image-hikey960-
.rootfs.img

Changed switch configuration from:
1 On, 2 Off, 3 On
then back to
1 On, 2 Off, 3 Off.

Connected USB to UART to Hikey and executed
screen /dev/ttyUSB0 115200, then connected power to Hikey.
The Hikey starts to boot up then hangs up at usbloader: bootmode is 4
Here is the tail of the boot output

mntn: kernel dump is not available
mntn: reboot_type is 125
mntn:
no need to dump_mem…
mntn: enter [registe_pstore_ramoops_dump]
mntndump: get_mntn_dump_addr:mid[5] is not init
mntn: no mdump_pstore info
mntn: M3_RDR_SYS_CONTEXT_BASE_ADDR is null
uart_cfg: [MNTN]:Could not find node.
uart_cfg: set_default_uart_cfg: uart_from_dts_read failed!
uart_cfg: module_idx 2, uart_no 6
uart_cfg: odule_idx 11, uart_no 15
uart_cfg: module_idx 2, uart_no 6
uart_cfg: getU32byCompatible(hisilicon,fastboot, uart-board-type) error!
uart_cfg: boardid: 5301 use uart port: 6
pasr: in pasr_init-43 …ddr: current logic version is lpddr4 verison !!!
ddr: current logic version is lpddr4 verison !!!
dtimage: -----can not find huawei,lcd_panel_type node by compatible
display: [display]get_detect_type: huawei,lcd_panel_type: get detect_type fail
display: lcd:no lcd detect_type
no_module: [LOGO] get_logo_buffer_from_dtsi: Could not find path /reserved-memory/logo-buffer.
no_module: [LOGO] logo_init: logo init failed!!! used the default fb addr.
display: [display]jdi_nt35696_panel_init: lcd type is not JDI_NT35696_5P5_LCD.
display: [display]jdi_otm2503b_panel_init: lcd type is not JDI_OTM2503B_5P5_LCD.
bfm: : >>>>>enter set_boot_stage
bfm: : bootStageCode is 0x02010002, mntnStageCode is 31
bfm: : <<<<<exit set_boot_stage.
dtimage: -----can not find huawei,lcd_panel_type node by compatible
display: [display]get_dts_value: can not get huawei,lcd_panel_type, bl_bus_id=4!
dtimage: -----can not find ti,lm36923 node by compatible
display: [display]get_dts_value: can not get ti,lm36923, support=0!
display: get lm36923_support failed!
Audio_codec: [audio]:Could not find “hisilicon,codec-controller” node.
load_teeos: can not find fb node fingerprint
load_teeos: failed to find fb node ese_config
display: [display]hisi_get_disp_info: hisifb_data is NULL pointer, return!
bfm: : >>>>>enter set_boot_stage
bfm: : bootStageCode is 0x02010003, mntnStageCode is 32
bfm: : <<<<<exit set_boot_stage.
misc: [get_misc_message] mmc_read failed
preboot: [fastboot]: check_unlock_misc_info, line:1273 :get misc message failed.
preboot: [fastboot]: check_powerkey_misc_info, line:1242 :!!!CAUTION!!!:get keypad_operator FAIL!
preboot: [fastboot]: check_volumekey_state, line:943 :!!!CAUTION!!!:get keypad_operator FAIL!
misc: [get_misc_message] mmc_read failed
preboot: [fastboot]: comm_read_misc_cmd, line:501 :get misc message failed.
watchdog: Disable watchdog start
bfm: : [disable_boot_fail_system] boot_fail_system state is 0
rescue: ^^^^^^^^^[rescue_init] ok !
usbloader: bootmode is 4

Seems the device is still in fastboot mode?
Anyone have any insight?
Thanks!


#2

This requires installation of uefi bootloader, did you follow these steps:


#3

Hey Loic,
Thanks for the reply. That is for building the boot loader from source right? I flashed UEFI from the snap shots.
Forgive me if I ask a silly question. I did some embeded programming in my CS degree, but it has been out 2 years.


#4

If you speak about the boot***.uefi.img, this is not enough, this only means that this is bootable by the UEFI bootloader.

You can find UEFI prebuilts here:
http://builds.96boards.org/snapshots/reference-platform/components/uefi-staging/latest/hikey960/release/

interesting to read: