Kernel 4.9 compile


#1

how to build kernel 4.9 for the 960. kernel 4.4 build’s fine from android source, but 4.9 has no defconfig for hikey 960.


#2

In the hikey960-v4.9 branch, support has been added to arch/arm64/configs/defconfig


#3

Would be interesting to see GB4 results using 4.9 kernel


#4

Has anyone had any luck with getting 4.9 compiled and installed on AOSP yet? In theory, Geekbench should work. It’s sideloadable at least.


#5

Is this working on aosp as well or just oe


#6

Has anyone got 4.9 compiling successfully yet?


#7

I know for a fact that it works on the openembedded platform… Will check on aosp in a few days. Any specific feature of 4.9 you are looking forward to?


#8

I’m more just tinkering and familiarizing myself with the build process, both for Android and the kernel, so that I’m no longer a complete novice with this system. I have a list of features I’d like in order to do most of the things I want, such as full USB drive support, and I suspect they’re more likely to appear in 4.9 first, if not already.


#9

The best place to follow is source.android.com/source/devices specifically for aosp on HiKey 960

And can you elaborate “full usb support” afaik usb3 works fine on 4.4 aosp


#10

The critical word there was “drive”. USB Storage simply isn’t working on any of the versions I’ve flashed. I need TB-scale storage for software testing on this platform, and haven’t yet found a workable solution within a reasonable budget. Admittedly I’m a week or two out of date, so maybe that’s changed?


#11

i wouldn’t place my bets on 4.9 yet. As of build 64 of the openembedded linux. USB ports don’t seem to be working at all, I don’t know about the android common kernel though…


#12

@ric96 Are the ports working with OE build 63 or older?


#13

Nope, not upto 64, haven’t had the chance to test newer builds…


#14

Hi i have tried with kernel 4.9(hikey-linaro) on hikey960 with latest andoid master branch.
Below are the some observations.
1.SPI2 communication is ver very slow even have set spi clock speed to 8mhz.
2.I2C bus communication speed also very slow.

I am suspecting on temperature , due to that reducing clock speed.
Any idea on this issue please help?
Note: with 4.4 kernel its working as expected


#15

I have tested USB on OE build 76(with kernel built from hikey960-v4.9 branch). USB doesn’t show up at all on dmesg.
So, on build 76 of OE, USB is a no go.


#16

I’m not sure if it will work but newer oe builds are http://snapshots.linaro.org/reference-platform/embedded/morty/hikey960/
give them a shot


#17

I tried, on build 87 of OE, usb is not working