Init: Warning! Service fuse_uicc0 needs a SELinux domain defined; please fix!


#1

Hello,
anybody please help to fix this warning which i am ghetting after dmesg.
because of this warning in dmesg i am not able to load my kernel module.and also my wifi module also not get loaded.when i do lsmod,its not showing anything.i am using android 6.0.marshmallow on ubantu 14.4.


DB410C Android serial console login
#2

the warning is…
init: Warning! Service fuse_uicc0 needs a SELinux domain defined; please fix!


#3

This does not happen with the stock Android build for DB410C. Where does you build come from?


#4

[actually let me rephrase that as: This does not happen <for me> with…]


#5

same android source code i build on ubantu 12.4.on that i am not getting any warning.but when i build on ubantu 14.4.and when i flash the boot.img. i am getting this warning.and also wifi driver wlan.ko is not loading automatically,i need to do insmod wlan.ko then it is loading.
i am not getting how to solve this issue


#6

I have written one tty driver.but whenever i load it it.insmod is showing device or resource is busy.so i came to know that console ttyHSL0 is using the tty layer.so my module is not getting loaded into the kernel.so i disabled the CONFIG_SERIAL_MSM_HSL_CONSOLE from the config file.and also BOARD_KERNEL_CMDLINE i changed from BoardConfig.mk file.after changing this two files.i compiled the kernel and replaced boot.img.then i tried to load my tty module.but insmod showing device or resource is busy.

am i using the proper way to disable the console ttyHSL0.


#7

Actually it turns this can happen for me with the stock Android build. It didn’t happen the last time I tried it (when I progressed as far as bug 417 instead) but I experimentally tried installing the 16.06 (binary) build and it is getting stuck just as yours does.


#8

Let me try again (following my own advise w.r.t. to Android which is to be very patient as it boots as all the first-boot optimizations take a long time)…

I am running the 16.06 binary build and the serial console is continually issuing the same warning messages you have highlighted:

[  240.443188] init: Warning!  Service fuse_uicc0 needs a SELinux domain defined; please fix!
[  240.453947] init: Starting service &#039;fuse_uicc0&#039;...
[  240.460297] init: Starting service &#039;ims_rtp_daemon&#039;...
[  240.481402] init: Service &#039;fuse_uicc0&#039; (pid 9839) exited with status 1
[  240.487137] init: Service &#039;fuse_uicc0&#039; (pid 9839) killing any children in process group
[  240.495715] init: Service &#039;ims_rtp_daemon&#039; (pid 9841) exited with status 1
[  240.502035] init: Service &#039;ims_rtp_daemon&#039; (pid 9841) killing any children in process group

However I can confirm that this warning does not interfere with the correct operation of WiFi. My board has booted to UI and once I have worked around bug 417 (using a wired USB mouse instead of a wireless mouse/keyboard), I am able to connect to WiFi and browse to sites using FireFox.


#9

I think this issue is caused by the modifications on storage management of Android 6.0. The DB410C development group may omit such change and directly use the same init scripts as the 5.0’s.
More details are revealed here:

Here’s my workaround:

BTW, the Qualcomm proprietary binary “ims_rtp_daemon” is malfunctioned here. The workaround for this issue is also provided here:


#10

Thanks! This issue is now being tracked on https://bugs.96boards.org/show_bug.cgi?id=472.


#11

Thanks for everyone who involved in this discussion.
init warning is not affecting on any other functionality,but my wifi module is not getting loaded while booting the board, I am manually loading that driver, I need somebody’s help to solve this my issue with wifi.