I am getting extremely frustrated with this board - Please help


#1

So I have tried the following things:

I got another board since I suspected the last one was kaput. I attached a USB cable to the type C cable that is marked the UART cable. Attached the other end to a laptop running Linux. Started minicom and powered up the board. Board started booting. Let it be for about 20 minutes and came back and looked like the board was booted up but there was no login or any command prompt on the console. The board wouldn’t accept any keystroke inputs.

So I powered down the board, detached the USB C cable, attached a USB mouse and cable and a new HP monitor with 1920x1080 60 Hz via the HDMI. Reapplied power to the board. Nothing. I do periodically see the LEDs between the USB A connectors flash.

Powered down the board. Detached the HDMI. Connected the USB-C back to the UART port. Now the board looks like it starts booting up, gets a bunch of errors (not being able to read files, etc.) Then reboots and the thing goes into an infinite loop of boots.

Brought the board down. Detached everything. Followed the recommended procedure for a Lebian load. (Used the flash-minimum-binaries.sh). Reset the DIP switches, connected the keyboard and mouse to the USB-A ports and the monitor to the HDMI. Applied power to the system. Nothing.

Brought the system down. Attached the USB-C to the UART port. Powered up the system. Nothing.

Brought the system down. Attached the USB =-C to the USB-C port and followed the directions to reflash the recovery mode (which should load everything). Didn’t seem to take anywhere near the 3 minutes the document said. In fact took 69 seconds since the script prints out the time.

Brought the system down. Reset the dip switches. Attached the keyboard, mouse and monitor. Nothing.

I’m about to bust an aneurysm. Anyone have any ideas.


#2

First note that I do NOT have a hikey970. I have a few 960’s. As far as I understand though, in regards to display, they are more or less the same.

That being the case, I would suggest that you try SEVERAL DIFFERENT MODELS of display on it. These SoC’s do NOT have native HDMI ports. They provide HDMI via a DSI-to-HDMI bridge (ADV753x). The problem with this approach is that some of the clock signals needed by the HDMI are not able to be provided at the exact frequencies required BY HDMI, which means that they are incapable of providing, for example, 1920x1080@60. Instead, what you actually get is 1920x1080@58. Many monitors/TVs do not accept this variation, and will display “no signal”.

I would recommend that you start by putting factory Android back on the board, find a monitor that gets it to actually display, and once you get an interface going on it, then start messing with other OS. When Android is on the board, you can put your USB-C cable in the socket between the HDMI and a USB-A port, and obtain console access via ADB.


#3

Thanks. I will try that again. Though it seems something else happens after you connect an HDMI monitor to the board, because my board then refuses to boot at all. And I first tried this with the factory loaded Android. I only went to Lebian in an attempt to see if this was some Android issue.

The condition my board is in now is reflected in this post