How to set permanent mac address to poplar board?


#1

I found that my poplar board mac address is keep changing every reboot, hence i failed to tie a fix ip to it.

Any way i could configure it with fix IP ?

Thanks.


#2

update:
Tried to set ethaddr on uboot, end up getting this error while booting up
Error: gmac1 address 93:de:31:cf:cc:b0 illegal value


#3

Your address is wrong because the very first bit is set to 1, which means multicast address. I assume you need to assign a valid unicast address here. (e.g. 92:de:31:cf:cc:b0, 94:de:31:cf:cc:b0…)


#4

Yes, i have updated with an valid mac address through an online MAC address generator, but it only set to uboot env, hence, MAC addr is still keep on changing everytime i reboot … arrgh


#5

Have you tried saveenv to preserve settings after reboot?


#6

Try to set “mac-address” property in DTS GMAC node, something like:

mac-address = [4a d3 bd 30 d0 2a];


#7

For record, I just pushed a couple of commit to Poplar U-Boot repo [1], to support generating MAC address from eMMC PSN (Product Serial Number) and passing it to kernel via device tree. That said, running this updated U-Boot, the issue of changing IP address from boot to boot should be gone now.

[1] https://github.com/96boards-poplar/u-boot


#8

Thanks Shawn, my board is getting static MAC now.