How to fix MIPI DSI output to LP11 during the kernel boot?

custom_board

#1

Is it possible to fix the MIPI DSI output to LP11 with the driver during the kernel boot process?
How do I do it if possible?


#2

Hi @Xen:

In general the MIPI-DSI signals should be held in the LP11 state (Low Power 1,1 state where both signals on each lane are at held at signal level 1 which is 1.2V) during initialization, which is exactly what you are looking for.

However, the 820c is running the boot-loader sequence from a cell-phone, and the very early boot loaders want to throw up a splash screen to show signs of life. Unfortunately only some Qualcomm employees have access to the source code for early stage low-level boot loaders, and we (non-Qualcomm employees) cannot change them.

Since you are asking about this, I suspect the early loaders are sending MIPI commands to your device and confusing it. I can suggest two things for you to try: 1) after the kernel comes up if you can power-down your display, then power it back up that should reset it and then you can initialize it correctly, or 2) you could add hardware to your board to isolate the MIPI-DSI display signals (hold them at the LP11 state) until you are ready to initialize your display. Finally 3) I suggest you file a bug about this at bugs.linaro.org I am pretty sure Linaro cann’t fix this, but at least the bug can be tracked and hopefully fixed someday.

Hope this helps.

Full disclosure: I am currently unemployed and looking for work.


#3

Hi ljking,

Thanks for your comments.
I found that the DSI signals are in Hi-Z state before completion of the initialization after powered on.
So, pulling those pins to high makes it in LP11 state against the bridge device, and solves the initialization issue.
The initialization of the MIPI DSI circuitry takes longer than that of the bridge device.
This was the issue I faced.

Thanks a lot.


#4

Brilliant, nice work-around, I’ll keep that trick in mind. (How to I mark this issue as solved?)

Full disclosure: I am currently unemployed and looking for work.


#5

Hi ljking,

Yes, you can mark this issue solved.
The hard-wired reset can be a solution to put it in LP11, but impractical.
Thanks a lot.


#6

@sdrobertw or @srini, how do I mark thread “solved”, I probably missed the button somewhere on the screen.


#7

I think making it possible to mark threads as solved was @Mani’s baby. Currently I don’t think is enabled for any of the topics.


#8

@danielt @ljking

This feature has been there for some time but not enabled on any categories. I will talk to IT team for enabling this across all categories or atleast to Dragonboard410c inoder to get a feel of it.

Thanks,
Mani


#9

@ljking @danielt We have enabled the Mark the thread as Solved option for Dragonboard410c category. For now, only the topic owner and staff can mark the thread as solved.

Thanks,
Mani