How do i can stop com.android.phone service on android version


#1

hi all
i flash latest android version download link: http://builds.96boards.org/releases/dragonboard410c/qualcomm/android/16.06/dragonboard410c_sdcard_install_android-118.zip
the version working to well at 410c .but always had one tips :Unfortunately the process com.android.phone had stopped
can i remove come.android.phone service file by adb ? how i doing pls tell me thanks


#2

i found dragonboard410c_sdcard_install_android-99.zip version can working to well . but this is version no lsusb :frowning:


#3

Hi puzhi,

Have you looked at your logcats to see what creates the crash? If you post, I can take a look as well.


#4

Hi Puzhi,

From http://www.96boards.org/forums/topic/android-6-0-marshmallow-on-dragonboard-410c/
Hello,

I have made the following changes to disable phone component and it works properly:-

in build/target/product/telephony.mk
PRODUCT_PACKAGES :=
#CarrierConfig
#Dialer
#CallLogBackup
#rild

PRODUCT_COPY_FILES := \

in build/target/product/core.mk
comment Telecom and Teleservice

in device/qcom/msm8916_64/system.prop
change ro.telephony.default_network=0
telephony.lteOnCdmaDevice=0

in vendor/qcom/proprietary/common/config/device-vendor.mk
#PRODUCT_PACKAGES += $(QTI_TELEPHONY_FWK)
#PRODUCT_PACKAGES += $(TELEPHONY_APPS)
#PRODUCT_PACKAGES += $(QTI_TELEPHONY_FWK)
#PRODUCT_PACKAGES += $(QTI_TELEPHONY_RES)
#PRODUCT_PACKAGES_DEBUG += $(TELEPHONY_APPS_DBG)

Let me know in case of further issues.
Thanks

Eleven


#5

See here for another fix to the issue (which doesn’t disable telephony): https://bugs.96boards.org/show_bug.cgi?id=417#c2


#6

11’s solution works to me.

Thanks.