Hikey970 factory images


#1

Hi,

I tried installing google play and google play services onto Hikey970. After many trials, my HDMI display was gone. So, I thought of installing back the factory images to the board to get it to original position.

The links below gave the factory images:
http://www.lemaker.org/product-hikey970-download-83.html and http://hihope.org/resource/hikey970_android_8_images.rar
@ric96, do you know of any other link where I can get factory images for Hikey 970(AOSP)

But the problem is, I still am stuck with no display on HDMI even after flashing factory images (boot, system, userdata, cache).
I clearly see the below log repeatedly getting printed in the logs (adb logcat). Anybody having a proper factory images built for Hikey 970 ? Any ideas at all ?

01-01 00:00:54.225 5203 5240 W StreamHAL: Error from HAL stream in function get_presentation_position: Operation not permitted
01-01 00:00:54.226 5258 5258 I crash_dump64: obtaining output fd from tombstoned, type: kDebuggerdTombstone
01-01 00:00:54.227 2868 2868 I /system/bin/tombstoned: received crash request for pid 5100
01-01 00:00:54.227 5258 5258 I crash_dump64: performing dump of process 5100 (target tid = 5100)
01-01 00:00:54.228 5258 5258 F DEBUG : *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
01-01 00:00:54.228 5258 5258 F DEBUG : Build fingerprint: ‘Android/hikey970/hikey970:P/OC-DR1/403:userdebug/test-keys’
01-01 00:00:54.228 5258 5258 F DEBUG : Revision: ‘0’
01-01 00:00:54.228 5258 5258 F DEBUG : ABI: ‘arm64’
01-01 00:00:54.228 5258 5258 F DEBUG : pid: 5100, tid: 5100, name: surfaceflinger >>> /system/bin/surfaceflinger <<<
01-01 00:00:54.228 5258 5258 F DEBUG : signal 6 (SIGABRT), code -6 (SI_TKILL), fault addr --------
01-01 00:00:54.228 5258 5258 F DEBUG : x0 0000000000000000 x1 00000000000013ec x2 0000000000000006 x3 0000000000000008
01-01 00:00:54.228 5258 5258 F DEBUG : x4 fdff6766746e7167 x5 fdff6766746e7167 x6 fdff6766746e7167 x7 ff7f7f7f7f7f7f7f
01-01 00:00:54.228 5258 5258 F DEBUG : x8 0000000000000083 x9 0000000010000000 x10 0000ffffc05554d0 x11 0000000000000001
01-01 00:00:54.228 5258 5258 F DEBUG : x12 0000ffffc05550e8 x13 ffffffffffffffff x14 ffffffffff000000 x15 ffffffffffffffff
01-01 00:00:54.228 5258 5258 F DEBUG : x16 0000b591e5273f98 x17 0000f1133743f608 x18 0000ffffc055488d x19 00000000000013ec
01-01 00:00:54.228 5258 5258 F DEBUG : x20 00000000000013ec x21 0000000000000083 x22 0000f11338bb3198 x23 0000f11336fca660
01-01 00:00:54.228 5258 5258 F DEBUG : x24 0000f11338bb3198 x25 0000ffffc0555730 x26 0000ffffc0555699 x27 0000f11336fca678
01-01 00:00:54.228 5258 5258 F DEBUG : x28 0000f11336fca660 x29 0000ffffc0555510 x30 0000f113373df3fc
01-01 00:00:54.228 5258 5258 F DEBUG : sp 0000ffffc05554d0 pc 0000f113373df424 pstate 0000000060000000
01-01 00:00:54.229 5258 5258 F DEBUG :
01-01 00:00:54.229 5258 5258 F DEBUG : backtrace:
01-01 00:00:54.229 5258 5258 F DEBUG : #00 pc 000000000001e424 /system/lib64/libc.so (abort+120)
01-01 00:00:54.235 5203 5240 W StreamHAL: Error from HAL stream in function get_presentation_position: Operation not permitted


#2

I can see the display back again. There is nothing that was done, except the board was switched off for the whole night. I am not sure what could have caused the error. Just wanted to update. There is some instability somewhere.