HiKey960 can't boot in normal boot mode

Recently my HiKey960 with AOSP OS could not boot up in normal boot mode.
Previously it was OK to boot into Android, I plugged out the power cable and had lunch, then re-plugged the power cable and issue happened.
The LED did not light but CPU was still running.

The fastboot & recovery boots are OK.
I tried full flashing latest AOSP images built by my own, and Linaro snapshot images from https://snapshots.linaro.org/96boards/hikey960/linaro/aosp-master/1561/
Also tried recovery flashing (recovery-flash.sh) from https://github.com/96boards-hikey/tools-images-hikey960/
All these flashings were successful but normal boot mode was still NOK.

Unfortunately I don’t have the UART debug board and my USB-UART cable connected to LS 11, 13 & GND PINs couldn’t get any log through /dev/ttyUSB0

Do anyone have suggestion on this situation?
Can it be confirmed to be hardware damaged?

Best Regards.

Hmm, I had a buck converter on the bottom of the board go bad once, and it didn’t completely kill the board, but had some weird consequences.

Flip the board upside down and rotate it such that the USB-C port is pointing down. Find the JTAG header, and go directly LEFT from there to the 8-pin IC. That’s the part that went bad on mine. Check the schematics for the hikey960 and verify the voltage outputs from that chip to make sure they are within spec. If not, you’ll have to replace that chip.

Note that in addition to the 8 legs, it also has a solder pad, so you’ll need to use a hot air station to replace it if its bad. Search through this forum and you should be able to find the thread detailing it.

Good luck.

Thanks very much for your information.

I just checked the mentioned buck, the Vin (5V) and Vout(3.3V) were OK. I also checked other two bucks (12V to 5V/4.2V) and both were OK.

Your suggestion just gave me a hint, I would check peripheral ICs if any failed one blocked the normal boot.

Best Regards.