HiKey USB Limitations


#1

Does the ‘new’ LeMaker version of the Hikey have the same USB ‘design limitations’ as the original CircuitCo version?
I am unable to connect a keyboard/mouse, as this cripples the (USB/Ethernet) network throughput… 2.4GHz WiFi throughput is even worse…
This would not be such an issue, if I could actually get the semi-proprietary TI Bluetooth/WiFi setup to work…

Robert Gadsdon.
November 30, 2015.


#2

Unfortunately it still is: it is a limitation of the SoC.
One solution for your setup is to use a usb OTG hub.


#3

Thanks for the info - I was afraid that this was the case…

I did try a hub attached to the OTG micro-USB port, but it only recognised both the Ethernet and Bluetooth adapters at the “full” (slow) speed setting…

At the “high” setting, I get:
usb 1-1.4: new full-speed USB device number 76 using dwc2
usb 1-1.4: device not accepting address 76, error -71
usb 1-1-port4: unable to enumerate USB device

  • and lsusb only shows the Ethernet adapter, and hub/s…

RG.


#4

I can see what you are seeing on my side. Let me find more info about this OTG workaround.

This commit kind of sumarizes the situation with the host ports:

I did some code to make sure the host speed bus settings were always defaulting to the common denominator but we never merged it because I was told it had some impact on the OTG behavior:

In any case it wouldnt help with your use case.

We have tried BT input devices and found them to be functional. Which one are you using?


#5

The LeMaker version usb have the same design in the usb limitation.
And I guess if in future, we special a usb port just for low speed, while the other one is for high speed, so that we can use mouse&keyboard and other usb device at the same time.


#6

That is right, there is no way around that. The bus speed needs to be set to the lowest common denominator.


#7

This would not be such an issue, if I could actually get the onboard Bluetooth/WiFi combo to work… I had tried (cross)compiling the hybrid 96Boards/TI stack several times, according to the detailed instructions, but the BT firmware never loaded… Maybe this will be easier when the ‘old’ 3.18 base is updated? I have tried the hikey-mainline-rebase 4.x versions over several months, but the SDcard is never recognized… (booting with UEFI/Grub…)

For the time being, I will stay with headless operation, and a relatively stable August 3 version of 3.18…

Thanks…

RG.


#8

I am using 15.11 with the usb auto-negotiation patches I mentioned before to make sure the usb bus always runs at the highest possible speed - lowest common denominator.

Are you saying that on 15.11 BT/WIFI is not functional? It seems fine on my end.

Could you share any error logs (dmesg) please?