HiKey 960 Debian / Ubuntu Install

I’m working on trying to get either Ubuntu or Debian installed on the HiKey 960. It appears that there are broken links on the 96boards.org website that should point to some binary files but the link is broken.

I have tried at least 10 times to use the instructions on the website but after completing the recovery and fast boot instructions to flash the OS I turn on the board after changing the dip switches and no lights turn on.

Please advise.

For firmware/bootloader you can use this link: http://snapshots.linaro.org/reference-platform/components/uefi-staging/107/hikey960/debug/

Then you can flash boot and system partitions with the following images: http://snapshots.linaro.org/96boards/hikey/linaro/debian/48/

Hi Loic

Thank you so much for your links!!! I followed them and was successful in flashing the bootloader, boot, and system partitions. I do have a few more questions regarding this build.

I plugged in an HDMI monitor and see no screen.

I plugged in a keyboard, mouse, and usb to ethernet device with cable. The keyboard doesn’t light up at all, the mouse does, and the ethernet cable works.

I am able to login using:
User: linaro
Pass: linaro

In one of my previous distributions using Ubuntu I was able to resize the userdata partition but this build doesn’t have such a script.

Do you have any recommendations for next steps to get the screen and keyboard working? Also is there a way to resize the root partition to take up more of the flash like 10 GB - 20 GB?

Thanks!

The image is a ‘developer’ image, without GUI, that could explain why display is not enabled. I’ve not tried it myself, but you can have a look at this steps: Does latest rpb desktop image (Debian) supports hdmi on hikey960?

On which partition did you flash rootfs? userdata? then you shoudl have 24GB, if not you can try resize2fs (e.g. resize2fs /dev/disk/by-partlabel/userdata).

Ok, thank you Loic. I have read the thread that you posted. I’m fairly new to the linux kernel land so I will proceed with caution.

I did try re-flashing the rootfs on userdata and then I erased the system partition and now I do have 24 GB of space on my root file system.

I am perplexed because I tried this on another build and it didn’t work at all. Thank you for mentioning the resize2fs step… I tried that as well multiple times before and was unsuccessful.

The hikey960 also does not generate correct clocks for HDMI. If your monitor is especially sensitive to the correctness of the clocks, it will refuse to come on.