Help for Hikey970 beginner


#1

Hello everybody. I just bought a hikey 970 and comes with preloaded AOSP, my surprise has been that there is no app store to add more applications and that the documentation of the Board is not yet available an official distro in Debian.

Seeing the forum I saw that some of you have the Debian running, my question is, could you tell me the version you have and how to install? (sorry for my English but it is basic and my computer skills in Linux reduced)

Board based on the Kirin 970 - HI3670 Application Processor
More info: http://www.96boards.org/product/hikey970/ (Website coming soon…)
Buy now: https://www.seeedstudio.com/HiKey-970-Development-Board-p-3046.html


Boot from uSD - DIP Switch settings?
#2

Seems that apple has really caused a lot of damage to people’s perceptions of how things can and should work. Android has no need for an application “store”. You can install any Android application file directly (you will find file name extension of “.apk”). Click a link to an Android application file in a web browser to install it, or via adb “adb install somefile.apk”.

If you simply must use an application store, I suggest f-droid: https://f-droid.org/en/
… but you first have to install the application store… by clicking on it in the web browser, or via adb.


#3

Thanks for the help, the truth is that I am an Apple user, good observation.

About Debian, could you help me?


#4

There’s a working Debian and Ubuntu image on the lemaker site. Here’s the link http://www.lemaker.org/product-hikey970-resource.html


#5

Thanks for the help. I installed Lebian and it works stably but it seems that it is a minimal installation without drivers of Wiffi, Bluetooth and other components. Do you know how to install all drivers?


#6

The wifi works. You can connect to it using the nmtui command.


#7

Yes it is true!, you can help me with the commands that I lack to configure the rest of hardware (especially the PCIe M. 2 that my Samsung 970 EVO does not recognize me)
Thanks again (sorry but on Linux I’m newbie)

Edit. Sorry And how to increase the partition because with the command “resize2fs /dev/sdd12 # max usage of disk” I do not achieve more than 4, 5G


#8

I haven’t worked on the pcie so I don’t know about that. The Lebian image has a partition table which contains 4.7 gb for the system partition. Could you do fdisk -l and send me the output of the command.


#9

I have burned the image with FastBoot directly without doing any recovery before( (in mode minimun). Maybe that’s why I have so many partitions.

Device Start End Sectors Size Type
/dev/sdd1 256 511 256 1M Microsoft basic data
/dev/sdd2 512 3583 3072 12M Microsoft basic data
/dev/sdd3 3584 5119 1536 6M Microsoft basic data
/dev/sdd4 5120 8191 3072 12M Linux filesystem
/dev/sdd5 8192 73727 65536 256M Microsoft basic data
/dev/sdd6 73728 73983 256 1M Microsoft basic data
/dev/sdd7 73984 94463 20480 80M EFI System
/dev/sdd8 94464 98559 4096 16M EFI System
/dev/sdd9 98560 102655 4096 16M Microsoft basic data
/dev/sdd10 102656 106751 4096 16M Microsoft basic data
/dev/sdd11 106752 107263 512 2M Microsoft basic data
/dev/sdd12 107264 1307391 1200128 4,6G Linux filesystem
/dev/sdd13 1307392 1508095 200704 784M Microsoft basic data
/dev/sdd14 1508096 1508351 256 1M Microsoft basic data
/dev/sdd15 1508352 7805951 6297600 24G Linux filesystem

In Sdd12 I have the system and sdd15 appears to me as ’ data ’ and I see folders like ADB, app, Backup, Bootchart, etc (must be the AOSP that has not been deleted)


#10

You can flash the image to the 15th partition which is of 24Gb. So instead of sudo fastboot flash system do sudo fastboot flash userdata rfs-name. You’ll also have to make some changes to the kernel command line which is passed in grub.cfg file(change the sdd 12 to sdd15). Grub.cfg should be present in your boot/grub folder of the root file system.


#11

The grub points me to the sdd12 for what I understand when see it:

set default=“0”
set timeout=3

menuentry ‘Lebian 9 (HiKey970 Lebian)’ {
search.fs_label rootfs rootfs_part
linux ($rootfs_part)/boot/Image earlycon=pl011,0xfff32000,115200 clk_ignore_unused=true console=tty0 console=ttyAMA6,115200n8 root=/dev/sdd12 rootwait rw quiet efi=noruntime
devicetree ($rootfs_part)/boot/kirin970-hikey970.dtb
}

menuentry ‘Fastboot’ {
search.fs_label boot boot_part
chainloader ($boot_part)/EFI/BOOT/fastboot.efi

And regarding the first thing I understand is only run that command (sudo fastboot flash userdata rfs-name) within the Lebian image folder?


#12

There are 5 steps to be done.
Step 1: Mount the img into a folder .
Step 2:Change the grub.cfg(In the console= line instead of sdd12 make it sdd15)
Step 3: Unmount the img
Step 4:Make the switches to 1-0-1-0 and run the command sudo fastboot erase system
Step 5:Flash the img file using sudo fastboot flash userdata name-of-img(rfs).


#13

Thanks a lot, I’ll tryed


#14

Has the rfs expanded?


#15

Sorry for my delay. The command to type would be ’ sudo fastboot flash userdata hikey970-lebian9. img ’ or 'sudo fastboot flash shunya hikey970-lebian9. img ’ , which is the original name of the image and user default?

edit. Sorry, now I see that the image AOSP there is a userdata image but in Lebian image no. In Debian image there’s a folder called binaries with:

config hikey_idt
prm_ptable.img
sec_usb_xloader.img
sec_xloader.img
fip.bin l-loader.bin
recovery-flash.sh
sec_usb_xloader2.img

And out of the binaries folder these files:
flash-minimum-binaries.sh
‘Release Notes.txt’
boot-hikey970.uefi.img
hikey970-lebian9.img
flash-all-binaries.sh
lebian-rfs_flashing_guide.txt


#16

After making the change in the grub.cfg you have to flash using the command sudo fastboot flash userdata hikey970-lebian9.img


#17

Ok thanks again, now I’m at work, as soon as I get home I try it. Anyway in the case I want in the future clean all the UFS and fresh install it as I should do better?


#18

sudo fastboot erase system will erase the system partition. When you will use sudo fastboot flash userdata hikey970-lebian9.img it will first erase the userdata partition and then flash the image to that partition. So don’t worry about erasing the ufs


#19

Has not worked, the system has not loaded the login screen. I have returned to flash and still have the image but with the sdd12 with 4.6 g :frowning:

As I said, now that I have nothing configured, as I could delete all partitions and that the resized I left with the 64g?

edit. Maybe modify the image wrong, the image you were referring to was boot-hikey970.uefi.img or was it another?


#20

Here in the link is the image which supports 25GB userspace

https://drive.google.com/file/d/1mNtDHdg8Uw3trtGyokqhDwuPv35KoMkF/view?usp=sharing

Follow the following steps:
Step 1:
Make
Switch 1 : ON
Switch 2 : ON
Switch 3 : ON
Switch 4 : OFF

Step 2: Untar the Lebian Image

tar -xvzf hikey970-lebian-9.tar.gz
    cd hikey970-lebian-9

Step 3: Connecting Cables

Connect Type C USB cable to the host and board and make sure it is configured as ttyUSB0
Connect Power Adapter

Step 4: Run the following command to flash all the binaries

./binaries/recovery-flash.sh

Step 5: Remove the power supply and turn on the switches

Make 
Switch 1 : ON
Switch 2 : OFF
Switch 3 : OFF
Switch 4 : OFF

Step 6: Booting your image

**Remove USB Type C cable (important) 	
Connect HDMI cable.
Connect the Power Adapter.	

NOTE: Plug the HDMI cable before powering up.HDMI hot plug may not work.

Username:shunya
Password:shunya

After booting resize the root file system by using: sudo resize2fs /dev/sdd15