HDMI screen when device was booted without HDMI

Hi,
The Dragonboard 410c only outputs to hdmi display when the display is connected during boot time.
This creates a problem for us, as we have devices that are standalone, with no screens, but sometimes, when there is a problem and we need to debug something, we want to connect with an hdmi display (and keyboard) to check what is the problem, but we can’t.

How can we make it so that the device will output to HDMI even when it was not booted with hdmi?

Did you resolve the problem? I am having similar problem making a screenless device. However I noticed that the board does not work properly without screen attached. Did you find a solution to the problem?

What operating system?

The operating system is linaro

‘Linaro’ is not an operating system.

This has all of the supported operating systems for dragonboard 410c: https://www.96boards.org/documentation/consumer/dragonboard/dragonboard410c/downloads/

So again, what is the operating system?

Debian 9.4 (stretch)

That probably makes things a bit easier than if it were Android. Have you tried giving it a forced video mode via kernel command line?

It will be something like video=HDMI-1:1280x1024@60e

You will have to verify the “HDMI-1”, and set the parameters appropriately. And pay particular attention to the “e”, that is not a stray. It’s for “force enable”.

Here is a great reference for the parameter: https://wiki.archlinux.org/index.php/kernel_mode_setting

@doitright okay, but what should I do? What command line should I run or what file should I change?

For db410c that would be video=HDMI-A-1:1280x1024@60.

git clone https://github.com/96boards/dt-update.git
cd dt-update && make
sudo make install

Then extract current command line:

sudo dbootimg /dev/disk/by-partlabel/boot -x cmdline > cmdline.txt

Edit cmdline.txt (e.g. with vim) and add requested parameters video=HDMI-A-1:1024x768@60D

Update system with new command line:

cat cmdline.txt | sudo dbootimg /dev/disk/by-partlabel/boot -u cmdline

The following parameter works for me:

video=HDMI-A-1:1024x768@60D