Hard bricked 960?


#1

I have here in front of me a 960 that has the two green LEDs between the USB ports and the blue and orange wifi/bt leds blinking synchronously. Total blank on the UART1 console.

Just before getting into this state, I had only the orange wifi LED blinking.

I got into this state while testing the functionality of the power and reset pins. I am working on running the Hikey960 off a 2S LiPo battery pack with a 9V boost. This was running just fine…

Can I throw this one away? It would be the 2nd 960 in a week…the other one just gets really hot :slight_smile:


#2

If I were you, I’d pick a less expensive board for testing new hardware to make sure it doesn’t cause sparks. For example, DB410C is a very nice board that only costs $75.

I can’t imagine any damage being caused by the power and reset pins, unless you shorted them to something too high voltage. Try measuring the voltage on the power and reset pins, and report back what it is. What exactly was the sequence of events that ended with the “brick”?

Have you tried following the board recovery procedures?


#3

Haha I guess you’re right, altough it doesn’t hurt my private wallet, I’d rather spend the prototyping budget on other things than new HiKeys. Waiting for new ones to arrive is also annoying. I’m also somewhat concerned with not knowing the exact cause. Before it got into this blinking state, I did read some boot messages about a buck regulator failing. The 5V line is stil there but the 1.8V line is dead (could be that it is just not switched on yet). But I wasn’t using that anyway since it isn’t powerful enough for most peripherals.

I was kind of rushing this job which resulted in a pile of IC evaluation kit PCBs hooked up with mediocre jumper wire, so yeah I might have shorted something, somewhere.

The blinking still does leave some hope for recovery, although an explanation of the state that causes the blinking would be useful at this moment. Hisilicon, anyone? Meaning of blinking state?


#4

I cannot get into recovery (ON-ON-OFF is the combination to boot into recovery, right?). Voltage at the reset and power pins is just 1.8V.


#5

Having 1.8V on the reset and power pins is a good sign. That’s what they’re supposed to be – internal pull-up resistor, active low.

The 1.8V supply pin is not expected to supply power until the kernel is running.

Yes, ON-ON-OFF should put it into recovery mode. The 960 should be detected by your host as /dev/ttyUSBx. If it isn’t, then first make sure that your wire is good, try rotating the plugs on either end by 180 degrees (I’ve seen some wires that cheat on internal connections, and some laptops that don’t hook up all the pins).

Blinking means that something is going on, but we don’t really know what – it doesn’t necessarily mean that anything is working.

Have you tried using a different power supply?
I don’t suppose you have a log of those regulator failure messages, do you?


#6

I don’t have ttyUSB. I do have it with another 960 i still have so the cable is fine. There must be somebody who defined the blinking sequence, the question who is it and how to reach this person?


#7

Pff and another one died. On this one no blinking LEDs, only the RT2515H IC gets really hot! I’ll try to replace it, maybe it helps


#8

Aaand another is gone…I’m going to stop wasting these things now. Is there anybody out there that could help me dive into this issue?


#9

I think in order to help with this, is going to require some very explicit details about what you’re hooking up to it and how.

For instance, you said something about a “2S LiPo” battery. From a brief look through google, that appears to be a 7.4 volt battery intended for drones.

9V boost? What’s that exactly, and what is it for?

Are there any external connections? For example, a battery charger? Or is this entirely a battery <==> hikey connection sitting in the middle of a desk without any wires?


#10

The ‘setup’ is a fair bunch of breakouts and ic evaluation kits wired up together with loads if jumper wires. I believe the messy state and generally lousy contacts of the jumper wires, combined with me possible making mistakes might have caused this…but 4 times in a row?? Not sure.

It starts with a 2S Lipo pack (407080) with protection board, wired up to a MAX17261 EVKIT, which is in parallel with a BQ25882 charger EVKIT, which has a Polulu 9V boost converter (UV50 type, the blue one), which powers the Hikey960. All except the boost on I2C0.


#11

Here’s the thing about “4 times in a row”: unless and until you fix the problem, it is just going to keep happening.

And you still havent explained the purpose of the boost converter. The battery can feed the hikey960 directly. If anything, you might be better off with a REGULATOR to protect the hikey960 from the charger – that booster you have won’t protect it from overvoltage. If anything, if there is something wrong with the booster, it could be doing anything.

You also need to be absolutely sure that the polarity of everything is correct.


#12

The HiKey wants 8-18V. The battery pack runs from 8.4 down to 6. Therefore we need a booster? I checked the HiKey schematics, it has an OVP IC on-board


#13

8-18 are just the “basic CE requirements”. There is nothing on this board that requires more than 5v, given a small drop through the regulator, 6 volts should do the job.

Look at page 2 of the schematic. High voltage input goes only to 3 things; 4.2v regulator, 5v regulator and LS header. As long as the voltage is high enough to exceed the drop at the 5v regulator, you’re good.


#14

Hm that does make sense! However I remember having our application hooked up to a 30W lab supply and it really wouldn’t boot below 8V. I think it is because of current spikes. We pull up to 700mA on 12V. It will be even more in the new build. I don’t have all these extra peripherals hooked up now so I’ll have to do some more testing. With a high grade RC type battery pack, 6V may be doable!