GPS Software

they are not included by default in the image. please have a look at the release notes for last release :, and search for “Using the onboard GPS”

i recommend that you remove the hack you did by taking files from an older ubuntu image, first.

Also note that all the packages have been updated for 4.9 kernel now, so if you follow the instructions, it should just work. The last thing missing is an updated firmware where both audio and GPS coexist, so that we don’t need to manually start the DSP… this is not available yet, and this is why you need to start the DSP manually with qdsp-start script.

Hi ndec,

I follow your suggestion to do it again on #227,
and It works now.

Thank you for your help.

Hi Nicolas,
ive tried following your instructions by changing the qdsp-start script that is located under the usr/sbin directory and modified it to match the update, im using stretch build #219 also.
after running the commands all i get in the xgps is NO FIX in status bar and its been like that for like an hour, i have put the board on the ledge outside my window because ive read along the conversation that the reception is bad.
could you confirm that my steps were correct?
and if so, is seeing a NO FIX status means that its working but not getting a fix or is there a different problem?
because there is no other way of knowing if it works or not.
thank you!

It’s possible that you’re seeing the result of a fatal event (crash) which causes the Hexagon firmware to restart.

The system does handle this gracefully, but the GPS client does not. So if this happens you would need to restart the gps related services.

We’re working on extending the recovery handling to cover these services as well.


Hi again Nicoals,
just wanted to confirm that this change does work.
didnt quite figured out how to perform the change but i got there eventually.
xgps doesn’t seem to get any information but gpsmon gets data and displays it after a manual init of the services.

I have a doubt .can we detect the co-ordinates if we place the board in air sealed metallic container?
and what type of antenna we can use to improve the sensitivity?

The on-board antenna is very weak, I certainly wouldn’t expect the on-board antenna to work in a sealed metal box.

Instructions for adding an external antenna is here:

I have gone through that pdf. the thing which confused me is GPS data is
handled with android app. But I am not using android OS in my board. can it
be possible to Handle GPS data with LInux?
can we detect GPS coordinates with external antenna if the board is placed
in sealed metallic container?

Yes you can install gnss-gpsd (and xgps).
You can find instruction on release page:

Yes, for sure external antenna needs to be outside the metallic box. (same apply for other wireless radios, wifi, bt).

You can ignore the section on testing using Android but you will need to follow the advice in the PDF to make the board mods necessary to install a suitable antenna.

4 posts were split to a new topic: Is there a system clock in Drabonboard 410C?

A post was split to a new topic: Can I power DB410C from a 9v power supply?

Thank you for your reply and my apologizes for late reply. I am able to retrieve GPS data by install gps libraries but i want to use that values for my future programming. Can you send me an python code or example for retrieving gps data through python code?

I am getting gps values displayed on my terminal window with these commands:

sudo apt-get install gnss-gpsd gpsd gpsd-clients
sudo systemctl start qdsp-start.service
sudo systemctl start gnss-gpsd.service
sudo systemctl start qmi-gps-proxy.service
gpsmon –n

this is displaying me values in terminal window but i am unable to use them in my future programming.

Everything goes through the common daemon so there’s nothing DB410C specific, you are into general Linux programming now.

That means the various examples around the web should just work.

These look promising:

For me nothing works =[

I have installed the ubuntu core 16, on db410c.

When I tried run ‘sudo apt-get install gnss-gpsd’, the system returned:
E: Unable to locate package gnss-gpsd

When I tried run ‘sudo systemctl start qdsp-start.service’, returns:
Running in chroot, ignoring request.

When I tried run ‘sudo dpkg-reconfigure gpsd’, returns:
Running in chroot, ignoring request.
invoke-rc.d: policy-rc.d denied execution of stop.
Creating/updating gpsd user account…
Running in chroot, ignoring request.
Running in chroot, ignoring request.
invoke-rc.d: policy-rc.d denied execution of start.

And obviously, when I tried run ‘gpsmon’, returns:
gpsmon:ERROR: TCP device open error can’t connect to host/port pair.

Now, I installed the linaro OS, but without success with the command ‘gpsmon’. The gnss-gpsd still not is available on apt packages.

Can anyone help me with this?

The instructions in this thread are for the DB410C Debian images. I don’t think they will work on Ubuntu Core.

Hi @danielt, I uninstalled the ubuntu core and installed the Debian.
But not work yet.

The 18.01 release notes mention that GPS was shipped disabled in that
release so, from the timings of the success reports in the above thread
I assumed that @nageshkar was using a more recent snapshot but I guess
it is also possible they used 17.09 instead.

I’m afraid I haven’t fitted an antenna to my board so can’t really test
things here.

@anon91830841: do we need to use adopt a snapshot release?

using a recent snapshot, GPS is working. It can take a few seconds (less than 1 minute) for the DSP to properly come up, once the DSP is up and running, you can register the QC gps into GPSD with:

/usr/sbin/gpsdctl add pds://any

then any GPSd client should work and get data. It might take a minute or so to get a FIX.

Thanks @danielt and @anon91830841.

I downgraded Debian to version 17.09, and now works perfectly with gnss.