Fried DragonBoard?


#1

Hello,

After several times of failed Linux installations and boots, my DragonBoard seems to be fried. No response to power sources anymore. I tried supplying power to the GPIO, no results. Is there any way I can save the board? Or is it completely fried?


#2

IIRC all the lights on the board are under software control. That makes it hard to tell the difference between a bad software image and a fried board.

However if you have tried SD card recovery and nothing happens (both Android and Debian SD card recovery images should start blinking LEDs about six seconds after power on) then its likely there is a hardware fault of some sort.

You mentioned applying power to the GPIO, which worries me slightly. What do you mean here?


#3

Well, I actually have 2 DragonBoards. I applied power to the GPIO and plugged a USB-powered device in, the new untouched board could provide enough power for the LEDs in the device to light up. The I-think-it’s-fried board on the other hand could not. That way I was pretty sure that the board could not receive any power anymore.