Fastboot Installation Method for the DB820c (issue with the HDMI)


#1

I’ve flashed two DB820c through Fastboot Method with Debian release 173 (Desktop distribution), and both DB820c work normally.

However, when these same DB820c are flashed with release 175 or 176 (the latest release), the HDMI display doesn’t work (keeps blank after boot).

Has anyone noticed any similar issue with the newest Debian Release? Or may have a clue on what may be wrong with the install method I’m using (listed below)?

[RELEASE 173] (kernel 4.11)
BOOTLOADER: dragonboard-820c-bootloader-ufs-linux-29
BOOT: boot-linaro-buster-dragonboard-820c-173.img
ROOTFS: linaro-buster-alip-dragonboard-820c-173.img

[RELEASE 175] (kernel 4.14)
BOOTLOADER: dragonboard-820c-bootloader-ufs-linux-30
BOOT: boot-linaro-buster-dragonboard-820c-175.img
ROOTFS: linaro-buster-alip-dragonboard-820c-175.img

[RELEASE 176] (kernel 4.14)
BOOTLOADER: dragonboard-820c-bootloader-ufs-linux-30
BOOT: boot-linaro-buster-dragonboard-820c-176.img
ROOTFS: linaro-buster-alip-dragonboard-820c-176.img


#2

Some extra test results:

I’m testing with 2 kinds of HDMI Display:

  • SMALL DISPLAY : 96Boards LinkSprite 7" HDMI LCD / Touch Display
  • LARGE DISPLAY : Samsung large TV/Monitor

Symptoms:
[RELEASE 173] : works well with both kinds of display
[RELEASE 175] : doesn’t work at all
[RELEASE 176] : boot is unstable. Sometimes, after waiting longer than usual, there is HDMI signal for the LARGE DISPLAY, but mouse and keyboard do not work.


#3

hello!

thanks for your help and reports!

Build #175 should be discarded, it was a bogus build, and it used the wrong kernel. So 176 is the first build based on the 4.14 based release branch (and 173 is the last with 4.11 kernel).

For 176, once you’ve booted, can you please inspect /var/log/Xorg.0.log? what do you see there?

Then can you run (on the root serial console)

systemctl stop sddm

then:

fbset

and share its output?

Then, can you start Xserver with:

X&
export DISPLAY=:0 

And then report the output of:

xrandr

What I suspect (which I can see on one of my monitor) is that some video modes don’t work.

For example, in my case switching from 4K to 1080p bring the display back up:

xrandr --output HDMI-1 --mode 1920x1080

I am not seeing any USB issues though…


#4

Hello, Nicolas. Thank you for the reply.

Unfortunately, I don’t have a serial adapter for accessing the serial console, at the moment.

I have tried with 3 different types of HDMI display, but none seems to work with this latest release (176). And I couldn’t figure out what may be causing this issue.

Could you describe the exactly versions of bootloader, boot image and rootfs you are currently using with the DragonBoard 820c?


#5

I use the latest builds from snapshots.linaro.org.

as i said in my previous image, i have at least 1 monitor that does not work, so I definitely agree that we have a problem/regression… and we are looking into it…

using a serial console is very much recommended when hacking on these boards :wink:


#6

Yes. You’re right! I regret not having a serial adapter, for looking deeper into the logs.
I’m looking forward to the next release (177).
Thank you for helping.


#7

Which bootloader and kernel image combination works best for you right now?

Is bootloader build 30 and kernel build 182 working for you ?


#8

@domi, I’ve tried almost all recent images for the DB820c. At the moment, one combination that works best and is stable is:

  • dragonboard-820c-bootloader-ufs-linux-29 (BOOTLOADER)
  • boot-linaro-buster-dragonboard-820c-173.img (BOOT IMAGE)
  • linaro-buster-alip-dragonboard-820c-173.img (ROOTFS IMAGE)

The other newer releases (including 182) did not work well (in my particular case).


#9

we have found an issue with the most recent builds , and ‘some’ boards are not working well. we have a workaround that we are testing right now.


#10

Thanks. I can confirm that the 29/173 combination (4.11 kernel branch) works best for me as well.

@ndec It is not clear which to me which bootloader to choose for a given boot image. Also, should I use the qdl tool or the flashall script ? Thank you.


#11

yes, it is a bit unusual, but it’s quite messy these days… hopefully everything will be back to normal in the next few days.

#173 is the last build with the old kernel and it is stable. with this build use #27 of the bootloaders

Newer debian builds are now based on 4.14 branch which is being stabilized. Newer debian builds can use the latest bootloaders. The reason why we have a dependency on the bootloader, is because we include the GPT in the bootloaders, and in #28 we switch from userdata partition to the one called ‘rootfs’.


#12

I’ve just checked and confirmed that release branch 185 is successfully booting (with a large 27" HDMI Display; There still are issues with small displays).

I’ve known from other thread in this forum that some fix/workarounds have been pushed recently.

Is there any special instructions (apart from those described in the link below) for building the linux kernel for this latest branch release (185)?


#13

I noticed that the documentation has just been updated. That’s great. With the updated instructions (for building linux kernel for DB820c), now I’m able to rebuild the kernel/boot image.