Fastboot failure with RB3

We recently bought the RB3 Development kit. Trying to flash a Yocto build image with fastboot has not been successful after repeated attempts.

Documentation I am referring:

We also have our Yocto build images, but of course that does not make of a difference with fastboot failing. The images I am trying to work with.

Since the board came with some default Linux image, we tried to flash the boot and rootfs images. But, fastboot would continuously fail.

After reading on another forum post, that bootloader might need an update first, we tried that but since that also needs fastboot, it did not work. From what I understand, the different bootloader images also decide the GPT partitioning and affect the next stage boot/rootfs flashing.

Then tried recovery using EDL mode, which seemed to have worked looking at QDL stdout, but fastboot still fails.

The documentation says while connecting RB3 to host

  • RB3 must be powered off (unplugged from power)
  • S6 switch on RB3 must be set to ‘0-0-0-0’. All switches should be in “off” position

This means I cannot use USB debug port but after no output from running the script, trying to flash with debug console connected shows

Launching fastboot
Fastboot Build Info: Sep  5 2022 15:18:55
qusb2_1: hstx: 7
PLL1 locked: 5
usb_lane: 0
Fastboot: Initializing...
Fastboot: Processing commands
Fastboot Action (Press <Right> to select): SAT
Handling Cmd: getvar:has-slot:partition
Handling Cmd:

Fastboot Send Fail
Handling Cmd: getvar:is-logical:partit
Handling Cmd: download:0000b000:partit

DXE_ASSERT!: /home/buildslave/workspace/lt-qcom-bootloader-dragonboard845c/abl_linux/MdePkg/Library/BaseLib/SafeString.c (691): (DestMax > SourceLen)

The last message points to an error coming from ABL Linux which seems like a problem with UEFI firmware? (ABL Linux seems like a custom fork of EDK2)

Also, the official A845-2.160400.10.00350.1-P1-D-201909041517 image from Thundercomm for this kit/board gives no different results.

Can someone help and guide how to proceed further?

Where did you get your fastboot binary from? I don’t remember the details but I have occasionally had problems with outdated binaries when using the version of fastboot from the distro.

I have tried with the distro version as well as the binary from platform-tools from google. Here is the version from platform-tools.

fastboot version 33.0.3-8952118

The distro version shows

fastboot version 31.0.3p2-android-tools

Found an unexpected way to make this work.

Firing the flashboot command first makes it wait for a fastboot device to appear, after which putting the device in fastboot mode makes it work.

Also, instead of putting the board in fastboot mode via the hardware viz. pressing the VOL- button etc. it is much easier to just hit the down arrow when the board is booting up which puts the board in fastboot mode. Though, this only works if the bootloader is working.

Also, contrary to what the 96boards website says about all DIP switches being in off position, having the debug console connected helps because of the above.