Fastboot devices not recognizing the hikey board


#1

Hi Guys,

I am using windows 10 and when I connected the hikey as adb, it is detecting it and I can access it.
But when I tried to connect it as fastboot, I am getting nothing when I tried fastboot devices.

Am I need to install anything or anything that I need to change?


#2

It’s almost impossible to work with hikey at the bootloader stage on a windows machine due to the lack of compatible drivers. At least from personal experience, if you’re lucky enough to have it working on your windows machine, then the regular google usb driver from Android Studio should just work, which I assume is already installed on your machine, since you have adb working. If it doesn’t work, then you might have to spend a lot of time and effort to try to find, install and test different drivers online to try to get it to work, and possibly still fail in the end. Sometimes installing new drivers end up breaking connections to existing devices as well. A linux machine is highly recommended.


#3

Note that the same goes for a mac/osx machine, or possibly worse. Also note that a virtual linux machine hosted in a windows or mac/osx does not help either.