Error message when trying to run kmscube


#1

Hi All,

I tried to run kmscube on Dragonboard 820 and 410, and got the same error message in both cases:
“failed to set mode: Permission denied”

Has anyone encountered this before?

Thanks,
Eran


#2

that’s very odd…
just a couple of things, what debian build are you using and where did you get the source for kmscube ?


#3

On the 410 it’s build 283, on the 820 build 173, both were updated (apt-get update and apt-get upgrade).
I tried to use the build that comes with the build, I haven’t built from source.


#4

I have never tried the kmscube from the build, can you try and compile this source: https://github.com/robclark/kmscube
this basically is the unmodified aka vanilla source.


#5

hi,

I think you are trying to run kmscube while a GUI (X , or weston) is already running. It won’t work. kmscube will grab the graphics card and manage it, so you have to stop X/GUI first.

in our Debian images we use the SDDM login manager, so you can kill the GUI with

systemctl stop sddm

Alternatively, if you want to permanently boot to FB console (non graphics) instead of GUI:

systemctl set-default multi-user.target

#6

Thank you so much, @ndec, That worked beautifully!!