Error building Android 6.0.1_Marsh_Mallo_P2 - LA.BR.1.2.7-01010-8x16.0


#1

I have successfully synced the - Android Board Support Package vLA.BR.1.2.7-01010-8x16.0-4
I am getting this below error while trying to build this source. I have followed the setup guide and tried in both Ubuntu version 12.04 and 14.04. In both the system the same error is coming.

Can anyone help, please? Am I missing any package or anything?

Error Log:

Installing recovery patch to system partition
Traceback (most recent call last):
File “./build/tools/releasetools/make_recovery_patch”, line 53, in
main(sys.argv[1:])
File “./build/tools/releasetools/make_recovery_patch”, line 49, in main
common.MakeRecoveryPatch(input_dir, output_sink, recovery_img, boot_img)
File “/home/iota/linux_android_board_support_package_vla.br.1.2.7-01010-8x16.0-4/APQ8016_410C_LA.BR.1.2.7-01010-8x16.0_6.0.1_Marsh_Mallo_P2/build/tools/releasetools/common.py”, line 1398, in MakeRecoveryPatch
Warning: could not find SYSTEM/build.prop in
using prebuilt recovery.img from BOOTABLE_IMAGES…
using prebuilt boot.img from BOOTABLE_IMAGES…
_, _, patch = d.ComputePatch()
File “/home/iota/linux_android_board_support_package_vla.br.1.2.7-01010-8x16.0-4/APQ8016_410C_LA.BR.1.2.7-01010-8x16.0_6.0.1_Marsh_Mallo_P2/build/tools/releasetools/common.py”, line 1089, in ComputePatch
p = Run(cmd, stdout=subprocess.PIPE, stderr=subprocess.PIPE)
File “/home/iota/linux_android_board_support_package_vla.br.1.2.7-01010-8x16.0-4/APQ8016_410C_LA.BR.1.2.7-01010-8x16.0_6.0.1_Marsh_Mallo_P2/build/tools/releasetools/common.py”, line 83, in Run
return subprocess.Popen(args, **kwargs)
File “/usr/lib/python2.7/subprocess.py”, line 679, in init
errread, errwrite)
File “/usr/lib/python2.7/subprocess.py”, line 1249, in _execute_child
raise child_exception
OSError: [Errno 2] No such file or directory
make: *** [out/target/product/msm8916_64/system/bin/install-recovery.sh] Error 1


#2

@santanu,

after android codebase was synced,
do you remove all “.git” folder?


#3

No, I didn’t remove the “.git” folders.