Enable the mmu in u-boot


#1

Hi Experts,
I want to turn on the mmu in u-boot which I download from the 96board’s github.
I remove the define CONFIG_SYS_DCACHE_OFF in hikey_armv8a.h. However, the u-boot can’t boot up after enable the mmu(cache_v8.c).
WHY? The TTB seems setup OK in 64K granule.


#2

Out of curiosity, could you explain how you were able to use uboot with the
hikey? Also, did you succeed in powering up the hikey with uboot using default
config? I don’t seem to find any hikey_armv8a.h file. Is this file here
https://github.com/96boards/u-boot.git ?


#3

Hi JourneyTu,

Good question…I don’t know :frowning: In the latest v3 patches which I’m about to send to the u-boot mailing list icache is now enabled by default. However I hit the same problem as you when enabling dcache. I haven’t had time to debug it further.

U-Boot isn’t officially supported on HiKey, it is something I’ve been developing in my free time. So patches and help debugging issues such as this are very welcome :slight_smile:

regards,

Peter.


#4

Hi Slaco,

Some instructions on how to build flash u-boot can be found here http://people.linaro.org/~peter.griffin/hikey/hikey-u-boot-release_r1/u-boot-readme.txt

I’m in the process of upstreaming the support to the U-Boot project, however currently you will need to get the code from the 96boards U-Boot repo (hikey-rebase branch).

FYI my personal development repo is here https://git.linaro.org/people/peter.griffin/u-boot.git/ which should always have the latest set of U-Boot patches pushed to it.

regards,

Peter.


#5

Thanks Peter for the information.


#6

Thank you, Peter.