Dvb drivers issue appeard in debian 16.9


#1

Hi
I just flashed my db410c with the new 16.9 debian release from linaro
I formerly used the 16.2 version

I own a DVB-T2 dongle (dmesg log):
[ 447.818337] usb 1-1.2: language id specifier not provided by device, defaulting to English
[ 447.822837] usb 1-1.2: New USB device found, idVendor=0572, idProduct=c688
[ 447.825859] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3

On the 16.2 release i have compile the v4l-dvb drivers on my own using: https://www.linuxtv.org/wiki/index.php/How_to_Obtain,_Build_and_Install_V4L-DVB_Device_Drivers

I managed to use the instructins to operate the dvb use dongle and with the help of mumudvb to watch TV.
In current 16.9 version is seems there is a conflict with the compilation.

After i used the same method to compile the drivers i get an error:
exports duplicate symbol __media_device_register (owned by kernel)
it seems like best method to fix it is found in the link below:

Is it possible to address this issue in future builds?
Is there any tweak i can do inorder both media kernel modules will live together in current release?

Thanks
Idan


#2

hi,

it seems that the issue is coming from this commit:

===
commit 421770e8eed6cd1111db3500710c07cddc773379
Author: Nicolas Dechesne <nicolas.dechesne@linaro.org>
Date: Thu Jun 9 11:48:10 2016 +0200

arm64: configs: enable drivers for CSI camera

Signed-off-by: Nicolas Dechesne &lt;nicolas.dechesne@linaro.org&gt;

===

which was needed to enable the camera drivers. We could (and maybe we should) make these things as =m instead of =y so that they are modules.

I have opened this bug to track further progress:

https://bugs.96boards.org/show_bug.cgi?id=462


#3

Hi ndec
I see the bug is open for 1.5 months now with no comment.
Do you happen to know the progress?
Do you happen to know if there is an intermediate build with a fix I can try?

Thanks
Idan


#4

sorry, i forgot to update the bug. basically we could do CONFIG_MEDIA_SUPPORT=m instead of =y. however this is currently broken as some of our drivers don’t build with that config.

so we will fix that bug. I am still not sure if this will be enough for your issue though…

i am still not sure we can fix it for the December release though. but for sure in the next release.


#5

Hi ndec
Is there an update?
I see many snapshots since 30 Oct, is there a one with intermediate fix i can use?

Regards
Idan


#6

hi @idanre1, we are not planning any new release on the 4.4 branch anymore, the next release will be on 4.9 release branch, around the end of March. We can make the change there.

we had a local patch for 4.4 , i believe that fixed the issue, but it was probably never pushed. if you really need it now, i can try to dig it up.


#7

Hi
I can wait until March.
could you please assure this change will be there and won’t be missed?

Last time it was missed for some reason…

Thanks!
Idan


#8

Hi ndec
any update?

Do you know when this bug will be fixed?

Idan


#9

hi,

sorry about the delay, i am just back from vacations… to be honest, i thought this issue was fixed since we moved to 4.9 kernel, but i just checked and MEDIA_SUPPORT is still compiled as =y while our config snippet requests =m… so the issue is still there. I am sorry about that. we will check what’s going on there.


#10

Hi ndec
any update

Do you have an estimate when this issue will be resolved?


#11

it will be fixed in the 17.09 release , which will happen in the next 2 weeks. the changes was tested recently and pushed today into our kernel branch:

https://git.linaro.org/landing-teams/working/qualcomm/kernel.git/log/?h=release/qcomlt-4.9

https://git.linaro.org/landing-teams/working/qualcomm/kernel.git/commit/?h=release/qcomlt-4.9&id=f4feb382e577abca7f7a57b5d0e944762a0e6bca