Dragonboard Update Tool Not Allowing IoT Upload


#1

Hello,

I just got a dragonboard and I have been following the steps at https://developer.microsoft.com/en-us/windows/iot/win10/db410c and I am getting no progress form step 2. I have placed the device to USB Boot, connected the usb to the pc and to the board and then connect the board. I then run the dragonboard update tool and it tells me i need to move the USB Boot to “On” which it already is… Any thoughts? I think I have a bad board.

Thank you


#2

Hi @davidbcoulson,

When you have the pin 1 of the DIP switch S6 turned on, and connecting your PC and the DragonBoard 410C, and not being recognized, I am not completely sure but by reading this forum I have some possibilities.

One is that it works only when connecting microUSB - USB cable to the micro USB connector on the DragonBoard 410C.
The DragonBoard 410C will not recognized if the any device connected to USB type A connector of the DragonBoard 410C at the same time when trying to use microUSB.
Please remove keyboard, usb or any other USB devices from DragonBoard 410C.

Other possibility is the AC adapter and the DC plug.
The 96Boards uses EAIJ3 plug which is 4.75mm diameter with 1.7mm center pin.
The regular DC plug with 5.5mm diameter with 2.1mm center pin will not work.
Also, there are 4.0mm diameter with 1.7mm center pin (EIAJ2) in the market, but this will not work stably either.

And the AC adapter is 12V 2A.
The 5V AC adapter does not work.

After checking above and still not working, I only could suggest you the Windows IoT forum.
https://social.msdn.microsoft.com/Forums/en-US/home?forum=WindowsIoT


#3

Akira,

Thank you for your response. I am using the miniUSB from the dragonboard to a usb in the pc so that should not be an issue. I am also using a 12V 2A AC adapter which was provided by Arrow with my order of the dragonboard.

I have looked through the provided for and was not able to find anything on this issue. I am thinking it was my lucky day and i got the one bad board from the whole batch.

Thank you again,

David


#4

Hi David @davidbcoulson:

Did you check that the board was operational before trying to load Win10-IOT? Since it appears that you have not yet loaded Win10-IOT, I believe that you should be able to restore dip switch 1 and check that the board is operating (Android takes about 3 minutes to boot the first time, be patient).

I have followed the steps using on my Win7 machine, for me there was one challenge, extracting the ffu file from the iso image (Win7 doesn’t automatically mount iso images). To get around this I burned the iso onto a CD, and then coped the ffu file from the CD to local hard drive.

Once you power-up the 410c you should see Windows installing a device driver for the board (under Win 7 it installs “QHSUSB_BULK”). After you start the “DragonBoard Update Tool” it should show a green connection status. if the board is not connected it will show red. You can connect and power-up the board after you start the update tool and the connection status goes green almost instantly. The first time I clicked the “Program” button it failed, but I clicked the button again and it worked fine on the second attempt. Restore switch 1, and re-power the 410c, it shows a splash screen at about 12 seconds, and the core is up in about 30 seconds. Subsequent boots are about 4 seconds to the splash screen and 20 seconds to up and running.

Full Disclosure: I am an employee of Qualcomm Canada, any opinions I may have expressed in this or any other post may bot reflect the opinions of my employer.


#5

I had the same problem. Android was working fine, but the Windows update tool wouldn’t detect the board (with the USB BOOT switch turned on). Somehow, using a different micro USB cable fixed the problem. The connector of the first cable I tried was a very tight fit; the connector of the second cable went in easier, and it worked.

In general, my DragonBoard seems to be very finicky about USB connectors. It seems it won’t power up unless all USB connections are “just right”.