Dragonboard not coming out of fastboot


#1

I am trying to flash new image on dragonboard 410c. I put my device into ‘fastboot’ mode(by running ‘adb reboot bootloader’) and flashed aboot, boot, system, userdata, persist and recovery images on a windows machine (by running fastboot flash * *.img). The flashing was successful, but after that when I tried to reboot by ‘fastboot reboot’ or removing power cable, the device is still booting into ‘fastboot’ mode. I tried multiple times, but result remained same. The boot switches S6 were set to 0000, which I did not change at anytime.


#2

One question, are you moving from a Android installation to a Debian installation? If you are, it is best to load the board with the SDCard method. The Android fastboot is slightly different from the Debian fastboot and this will cause issues if you try to boot Debian with an Android fastboot or visa-versa.

Full Disclosure: I am an employee of Qualcomm Canada. Any opinions I may have expressed in this or any other post may not reflect the opinions of my employer.


#3

Thanks for the reply. I am trying to put android on top of existing android which came with the board. I figured out that the issue is with my build.
I downloaded linux_android_board_support_package_vla.br_.1.2.4-01810-8x16.0-3.zip and compiled it. When I try to boot from these images, the board does not boot. Then I installed 15.06 version from https://builds.96boards.org/releases/dragonboard410c/qualcomm/android/15.06/ through SD card. When I flash images from 15.06 the board comes up, but the images from my build fail to boot the board. Am I missing some step while building or is the source I have taken is wrong? Please guide me.