Dragonboard does not recognize mouse


#1

I have just received my Dragonboard 410c. When I connect keyboard and mouse to the board there is no response on mouse actions. The keyboard works just fine on both USB ports. I also tried a wireless mouse, it did not work. My wired Dell mouse is quite old, about 8 years but it works perfect with all my computers.

I really need help with this, the device is far too expensive to be thrown in the garbage bin. Since I live outside US I had to pay freight, custom fee and tax on top of the original price; in total $165!


#2

This is unusual. I have used a large number of different mice (both corded and cordless) and never seen an issue. Lets start with a basic question. Which operating system are you running. I am guessing that since you just received the board you are running the pre-installed Android image. Android turns off the mouse pointer most of the time until you move the mouse. The first thing you need to do is drag the unlock icon to the top of the screen to bring up the main window.

Did you try running the board with just the mouse (no keyboard attached)?

Also check that DIP Switch 3 (USB Host) is in the OFF position.

The default actions of Android is to have an unlock screen and to shut off the display in 1 minute. Usually the first thing I do is change the settings so that the timeout is Never, and the security is None.

Full Disclosure. I am an employee of Qualcomm Canada. Any opinions I may have expressed in this or any other post may not reflect the opinions of my employer.


#3

Thank you for your quick response.
Yes, I haven’t changed anything so I run the pre-installed Android OS. All DIP switches are in the off position.
Running the board without the keyboard does not make any difference. I have power to the mouse, the red LED turns on when I move the mouse. But there is no mouse pointer on the screen and the system does not respond to any mouse actions. In order to power off the board properly, after I pressed the power off switch, I had to connect the keyboard and hit the enter key.


#4

In the same situation I switched to a Logitech Wireless Touch Keyboard k4000 Plus, worked fine, dongle uses 1 USB slot