DragonBoard 820c Fastboot Failed - remote: data too large


#1

Hello,

I know this is the DragonBoard 410c forum but I hope I can find support for my topic here as well.

I am trying to flash Debian on my Dragonboard 820c following this guide:

I am able to boot my board into fastboot but when I try to flash the image an error occures:

FAILD (remote: data too large)

Do you have an idea how to solve this issue?
Many thanks in advance.


#2

hi,

which image are you trying to flash and in which partition? Is the file you try to flash a ‘sparse image’?


#3

Hi,

I followed the description on the web site I posted before.
So I tried to flash the image “linaro-stretch-developer-qcom-snapdragon-arm64-20170105-26.img” by using
fastboot flash system linaro-stretch-developer-qcom-snapdragon-arm64-20170105-26.img


#4

hi,

the instructions recommend to use userdata, not system. But normally it should work with system as well, since the image is not that big…

  • can you please share the output of “fastboot getvar all”?
  • can you share the boot log (on serial console)
  • can you try in userdata instead?

#5

Hi,

I tried with userdata before with the same result. The instruction says that I should try “system” instead if userdata doesn’t work, so I did it.
The output of “fastboot getvar all” is quite short:
all:
finished. …

Unfortunally I can not access the DragonBoard via serial console or I don’t know how.


#6

hmm. i am tempted to suspect an issue with your fastboot app (on your PC). what do you use there? Linux? Windows? can you provide more info on how you got fastboot installed?

can you use the same fastboot with any other boards?

can you try these commands as well:

fastboot getvar max-download-size
fastboot devices


#7

I use a Linux machine.
I have already used fastboot with other boards and never had any problems.
The installation command for my fastboot:

sudo apt-get install android-tools-adb android-tools-fastboot

fastboot getvar max-download-size doesn’t give me any information as well.
fastboot device shows me my connected board (98612ee fastboot)


#8

ok, maybe it’s the target side bootloader which is wrong/weird… without UART traces, it’s hard to debug.

let’s add a few more things…

can you add ‘-S 256M’ when you flash with fastboot? e.g.

fastboot flash system <file> -S 256M

and finally, can you try to flash an OpenEmbedded image instead? they are much smaller image, so i want to understand if the file size makes a difference.

http://builds.96boards.org/snapshots/reference-platform/openembedded/master/dragonboard-820c/rpb/129/rpb-console-image-dragonboard-820c-20170105084250-129.rootfs.img.gz


#9

ok, I tried “fastboot flash system <file> -S 256M” and the result was:

sending sparse ‘system’ (262140 KB)…
OKAY [ 8.755s]
writing ‘system’…
OKAY [ 8.144s]
sending sparse ‘system’ (262140 KB)…
OKAY [ 8.859s]
writing ‘system’…
FAILED (remote: size too large)
finished. total time: 31.715s

And when I tried the OpenEmbedded image it seemed to work fine:

sending ‘system’ (184508 KB)…
OKAY [ 5.864s]
writing ‘system’…
OKAY [ 5.872s]
finished. total time: 11.735s

But after powering the board, nothing showed up.


#10

hi,

i suspect that you have a different version of the bootloaders installed on your board. maybe an older one… unfortunately we can’t distribute bootloaders at his point of time, so you need to check with whoever ‘gave’ you this board to check if you can update. The fact that ‘getvar all’ doesn’t work is a sign that something is not correct.

the host side fastboot will use ‘getvar max-download-size’ to cut the file to flash into chunks. Using ‘-S 256M’ forces the chunks to be of 256MB which seems to workaround the issue, and clearly you could flash now (at least the OE image).

the last error ‘size too large’ means that you are trying to write an image that doesn’t fit in ‘system’ partition. Here again this is a sign that you are using a different bootloader version compared to all the versions I have seen so far… the OE image which is really small was flashed properly probably because it is small enough.

Maybe you can flash the debian image in ‘userdata’ with "-S 256M’, and it might go further.

About your last sentence, what are you doing after powering the board? You need to compile and run your own kernel. are you doing that properly?

Also let me emphasize that using Linux on DB820c without the serial console is really not recommended, the state of the s/w is such that you will have to get a serial console. I would recommend to get the necessary equipment for that, or we are going to waste a lot of time.


#11

Ok, first of all thank you for your effort and your detailed answers.

I just tried to flash the Debian image in “userdata” and it worked.
I absolutely agree with you, that working without a serial console is pointless, so I already order serial adapter.

So for now let me say thank you. Maybe I will come back after debugging.


#12

my output of fastboot ‘getvar max-download-size’ is ‘getvar:all FAILED (remote: no permission)’

please help me


#13

It is likely either that the fastboot program on your computer is out of date or that the bootloaders on your DB820C are out of date.