Dragonboard 410c - Failing to flash gpt_both0


#1

Hi, I’m trying to move from a Linaro distro (working just fine) to Android, but when I try to flash the bootloader, as suggested here:
“Instal Android Release” - https://github.com/96boards/documentation/wiki/Dragonboard-410c-Installation-Guide-for-Linux-and-Android#flash-the-bootloader-into-on-board-emmc-1

I’m running the procedures under windows 10 machine, but when i run the bat (i’ve just renamed the flashall to flashall.bat) it shows:
C:\dragonboard410c_bootloader_emmc_android-72>fastboot flash partition gpt_both0.bin
target reported max download size of 268435456 bytes
sending ‘partition’ (33 KB)…
OKAY [ 0.008s]
writing ‘partition’…
FAILED (remote: failed to write partition)
finished. total time: 0.040s

For all subsequent files it runs successfully, but for this first one it fails. I’ve tried to just ignore it and move forward, by after flashing the Android system images and boot the board, it never stops to pop up an error message related to android.phone process.

There is any further procedure that should be done here?
I’ve set the S6 pins all to 0, removed all usb and hdmi cables, left plugged only usb and power source.

Thanks,
Francesco


#2

The android.phone error is a known issue and not something you did. See https://bugs.96boards.org/show_bug.cgi?id=417 for more details. Could you try the images in http://builds.96boards.org/snapshots/dragonboard410c/qualcomm/android/128/ instead?


#3

hi,

i think i undersand why it failed. the gpt_both0.bin file in the most recent release for android bootloader seems to be invalid. I found a similar issue a couple of days ago in another set of bootloader files, and I believe the fix I did should also fix your problem.

can you please try the most recent bootloaders instead of the last release:

http://builds.96boards.org/snapshots/dragonboard410c/linaro/rescue/76/


#4

Thank you guys!! It worked just fine when I moved to other bootloader!