Dragon board 410C is not bootinhg up

Dragon board is powering up with solid blue BT light.
No HDMI output.
Even not discoverable in fast boot devices list in Linux.

What recovery procedures have you tried? If you haven’t tried much yet, I’d recommend re-installing using the “SD Card Method - Install and boot from eMMC” approach.

I tried reinstalling once again using SD as well as eMMC method. But the board is not responding except solid BT blue light.

As i mentioned earlier i tried to follow fast boot method as well. But as board is not discoverable, no files can be flashed.

Can there be any issue at hardware side?

The fastboot method relies on there being something useful in the eMMC so it is not suitable as a board recovery method… Only methods that boot from other media are suitable for recovery.

If you disconnect everything from the DB410C except for the power supply and the SD card, and configure the jumpers to boot from SD card then the expected result is a green LED flashing in a heart beat (thump-thump-pause) rhythm. If this does not happen it is likely the board is damaged and you should contact your supplier.

1 Like

Hi Sag_Rochwani,

I have the same issue right now.
In your case is it solved ? If it was can you guide ?

Thank you

Hello everyone,

Couple of days back I got the same problem and now it’s like new board.
These are the things I did…

  1. aka EDI mode
  2. Write the boot loader( try flash ./flashall instead of step by step as in document), boot image, RootFS image.
  3. Now remove everything and reboot
    Wait at least a minute…

Most of all get the latest images, i worked on old images before and it was failed. At last I tried the latest .117 boot loader image for Linux (there are bunch of other images, but specifically for Linux you need to search).

Have a nice day