Display blank after flashing custom kernel image on Linaro Debian Desktop


#1

Hi,

I am trying to build and deploy a custom kernel to DragonBoard410c with Linaro Debian Desktop.

I installed Linaro Debian Desktop (4.14) to eMMC using SD card installer (Option 1 in instructions). Desktop was displayed on the monitor.

Then I built and flashed a custom kernel using the instructions available on 96Boards website. I just wanted to change the kernel, so I didn’t flash the rootfs partition.

After the flashing is finished there is no display on the monitor. However, I can log in using the serial connection.
Is there some additional setup needed to enable display in the custom kernel build?

Both kernels have the same version (uname -r displays 4.14.0-qcomlt-arm64).

I tried building the new kernel image with configuration found in /boot/config-4.14.0+qcomlt-arm64.
I also tried extracting the device tree from the original image and flashing it to the new image using dbootimg.


Linaro Debian pre-built kernel configuration
Linaro Debian pre-built kernel configuration
#2

… but you did copy the kernel modules to the rootfs? That’s most likely where something could have gone wrong. Can you describe how you did it?


#3

Thanks for the quick respone!

The problem was solved after I built and deployed kernel modules for the custom kernel.