Debugging


#1

I have a HiKey Lemaker 2Gb board. I compiled Android 6.0.1 and flashed to the board. Now, I would like to develop some app for it. The board is connected to a monitor via HDMI, and I need a mouse to have a pointer device. The problem is the mouse is connected to one of the Type A USB host ports, while I connect adb via the micro USB port. Those ports do not work at the same time. I also have other peripherals like camera, and FTDI serial devices. How do you debug in such an environment? I tried to connect adb via wifi but it worked only once. Most of the times when I try to connect the board just crashes and reboots.


#2

adb over network is the ideal way to connect to the hikey so it is disappointing that this isn’t working for you. Can you share more details about how you setup adb over wifi and what log messages are coming from your PC and the hikey serial port?

Only other options are to avoid using the USB type A ports entirely. Either use a Bluetooth mouse or send pointer motion commands via ADB (something like: http://marian.schedenig.name/2014/07/03/remote-control-your-android-phone-through-adb/ ).


#3

I do not have serial port access. I saw the serial ports have 1.8V voltage level so I think I would need some level shifter or some FTDI device with the right level. When I try to connect with wifi the board simply reboots and the PC prints a timeout message. Is there some log file on the board where I could get some info on the crash after reboot?