Debian no /dev/spidev0.0


#1

Hello,
I am trying to enable spi on my DB, however, there’s no spidev listed under /dev … anybody any ideas?
Thanks,
Miriam


#2

There is no spi device exposed by default, you need to enable it in the device-tree:


#3

Thanks, on DBit’s working :slight_smile:
…but also working with another (similar though, also Snapdragon) board, GeniaTech Developer Board 4… thought it would work the same way, cause I’ve installed the same Debian version on both, but apparently it doesn’t boot properly anymore… any guesses?

I mean there are some discussions about this topic already (e.g. How to enable spi and access it in Debian os), however for beginners like me , it’s quite uncomfortable to catch up… so I’m looking for some prepared instructions about which content(s) I should add at what position(s) in kernel tree…


#4

What do you mean? enabling spi makes your board non-bootable ? can you share serial ouput of the boot ?
GeniaTech Developer Board 4 is not an ‘official’ 96Boards, so I don’t know about connector pinout.
You can try to flash the bootloader/fw with recovery instruction in order to be fully aligned with DB410C: https://www.96boards.org/documentation/consumer/dragonboard/dragonboard410c/installation/board-recovery.md.html, but again I don’t know if it’s fully compatible with this board.

NP, this is why I pointed to https://www.96boards.org/documentation/consumer/dragonboard/dragonboard410c/guides/enable-spi.md.html which explains how to add spidev node device-tree at runtime.


#6

Hey Loic,
thanks for your help.
Solved the problem by now, spi is working, followed the instructions you posted on linux debian for DB410c sd card emmc version.

Howerver, I figured out that when asked to reboot after executing the script,
I had to enter “sudo reboot”

when I switched off and on the device, the screen stayed black so that’s why I thought it didn’t work.


#7

However now I get this error message:


#8

don’t think it’s related to spidev enabling, did you change anything else?


#9

nope… but also not certain about the reason, as spi works after reboot