DB410C Linaro unable to see my office WIFI network

Hello,

I just got my DB410c boards with Linaro Stretch 9 pre-loaded. The problem I am facing is with the WIFI detection. The board is showing some of the WIFI networks in the air but not the ones in my office. I read a lot of support topics here but could not resolve my problem.

Actions taken

  • Update Linaro to the lastest build from linaro.org >> No change in situation
  • Removed Network Manager and Installed WICD >> No change in situation

Details of Access Point –
Make – Symbol/Zebra Technologies
Model – AP6522 – Dual Radio (2.4 Ghz, 5.0 Ghz)

I tried a couple of things on the access point also, but unfortunately the DB410c doesn’t detect my 2.4GHz ESSID.

Details of DB410c –
Operating System - Debian GNU/Linux 9 (stretch)
Kernel - Linux 4.9.56-linaro-lt-qcom

Any pointers of support would be highly appreciated.

Cheers !!
Rajat

It’s strongly recommended to update on latest, with 4.14 kernel, which includes many WiFi Fixes (I understand you did, but the 4.9 kernel does not reflect

Try lower level scanning, in a terminal:

sudo iw wlan0 scan

Does it report your AP? Can you do the same on an other computer and share the output part for the desired AP.

Also what is the frequency/channel of your AP(s).

Hello Loic

Appreciate your prompt response. I am not so familiar with Linux commands, but still can share what all i did.

  1. sudo apt-get dist-upgrade – to update and still I got the Kernel to be 4.9.56. In case I need to change some other settings, please guide me how to change to 4.14…

  2. sudo iwlist wlan0 scan – I can see some ESSID’s from different AP’s or routers but not the one with my office network. My channel settings is SMART and Power is also SMART. It is a Wing5 AP from Motorola/Zebra Technologies which manages the RF by itself. My AP supports both 2.4 and 5 GHz, and I have my devices using them appropriately. I know DB4 will only support 2.4. I have had similar problems with Raspberry Pi too and had a tough time getting it on the WIFI network.

Regards
Rajat

Yes the kernel is not updated when running an upgrade, because it resides in boot-image partition and not in as a file in the rootfs.

You can either use the SDCARD method or fastboot method to flash the latest release: https://www.96boards.org/documentation/consumer/dragonboard/dragonboard410c/downloads/debian.md.html

First, try latest release. I remember an issue with 5GHz AP not replying to 2.4GHz channel to force client on 5Ghz. This has been fixed with a patch which is not present in old releases (https://patchwork.kernel.org/patch/9958797/).
Issue can also be related to the regulatory domain, e.g. using channel 12 and 13 which are e.g. non allowed in US.

Hi Loic

Thanks for the help !! It is stated to detect my office wifi 2.4GHz ESSID.

Will keep this update as my GOTO for all deployments.

Regards
Rajat

Hi Loic,

Its me again, I am in amidst of a problem. I was updating the board using the SD card and eMMC boot method. It took a long long time and didn’t complete. After waiting for 30mins or so, with nothing on the HDMI screen, I switched off the dragonboard. Switched back S6 SD boot switch to OFF. Tried to boot it again. Its not coming back, What to do?

Please help.

Regards
Rajat Ratra

Which release are you trying to install? did you try the fastboot method?

Good news for me. I just re-tried the whole process with a new SD Card. It worked, my DB410 is back to work… Thanks !! and sorry for the bother.

Regards
Rajat