DB410 linaro hang up when shutdown

custom_board

#1

Hi everyone.

I am working with db410 (inforce6309).

When I type “sudo shutdown now”, the shutdown sequence is executed for a while and sometimes hangs up.
Then login prompt is displayed like the following. (The keyboard is not responsed.)

Debian GNU/Linux buster/sid linaro-alip tty1
Linaro-alip login:

About one or two minutes after, linaro will shutdown.

I hope the shutdown sequence is smoothly executed.

Linux version:
Linux linaro-alip 4.14.0-qcom-ifc6309-arm64 #17 SMP PREEMPT Wed Nov 21 20:28:59 PST 2018 aarch64 GNU/Linux

P.S.
debug console message when hangs up

message

root@linaro-alip:~# Stopping User Manager for UID 0. Stopping Authorization Manager…
Stopping Session 5 of user linaro.
[ OK ] Stopped target Sound Card.
Stopping Bluetooth service…
Stopping Daemon for power management…
[ OK ] Closed Load/Save RF Kill Switch Status /dev/rfkill Watch.
[ OK ] Stopped target Timers.
[ OK ] Stopped Daily Cleanup of Temporary Directories.
[ OK ] Stopped Daily apt upgrade and clean activities.
[ OK ] Stopped Daily apt download activities.
[ OK ] Stopped Trigger anacron every hour.
[ OK ] Stopped target System Time Synchronized.
[ OK ] Stopped target Graphical Interface.
Stopping Disk Manager…
Stopping Simple Desktop Display Manager…
[ OK ] Stopped target Multi-User System.
Stopping OpenBSD Secure Shell server…
Stopping Modem Manager…
[ OK ] Stopped target Login Prompts.
Stopping Serial Getty on ttyMSM0…
Stopping Getty on tty1…
Stopping LSB: set CPUFreq kernel parameters…
Stopping Regular background program processing daemon…
Stopping Internet superserver…
[ OK ] Stopped Initialize hardware monitoring sensors.
Stopping System Logging Service…
Stopping Session 3 of user linaro.
Stopping Save/Restore Sound Card State…
[ OK ] Stopped System Logging Service.
[ OK ] Stopped Regular background program processing daemon.
[ 386.925925] mipi-dsi 1a98000.dsi.0: 1a98000.dsi.0 supply vdd not found, using dummy regulator
[ 386.925976] mipi-dsi 1a98000.dsi.0: 1a98000.dsi.0 supply vddio not found, using dummy regulator
[ OK ] Stopped Modem Manager.
[ OK ] Stopped Disk Manager.
[ OK ] Stopped Authorization Manager.
[ OK ] Stopped Internet superserver.
[ OK ] Stopped OpenBSD Secure Shell server.
[ OK ] Stopped Simple Desktop Display Manager.
[ OK ] Stopped Serial Getty on ttyMSM0.
[ OK ] Stopped Getty on tty1.
[ OK ] Stopped User Manager for UID 0.
[ OK ] Stopped User Manager for UID 1000.
[ OK ] Stopped Bluetooth service.
[ OK ] Stopped Daemon for power management.
[ OK ] Stopped Save/Restore Sound Card State.
[ OK ] Stopped Session 1 of user root.
[ OK ] Removed slice User Slice of root.
[ OK ] Removed slice system-getty.slice.
[ OK ] Removed slice system-serial\x2dgetty.slice.
[ OK ] Stopped /etc/rc.local Compatibility.
[ OK ] Stopped target Network is Online.
[ OK ] Stopped LSB: set CPUFreq kernel parameters.
[ OK ] Stopped Session 5 of user linaro.
Stopping LSB: Load kernel modules needed to enable cpufreq scaling…
[ OK ] Unmounted /run/user/0.
[ OK ] Stopped LSB: Load kernel modules needed to enable cpufreq scaling.

[ OK ] Stopped Session 3 of user linaro.


#2

I solved this problem using the following URL.


#3

Good to hear. Thanks for the update!