Customized 32bit debian rootfs


#1

Hi,

I need 32bit debian jessie for the dragonboard.
Have anyone tried it before?
If not, How should I start?

Thanks


#2

yes, i have tried that already. it will work fine.

you have a couple of options:

  1. debian has support for multiarch, so you can install 32-bit packages in a 64-bit system. there are many docs/wikis out there to help you do that. that will give a mixed system where you can install both 32 abd 64 bit apps

  2. you can create a complete debian rootfs from scratch using debootstrap and make it 32-bit. From there you can add all the components you need to make up your own custom systems

  3. you can use our prebuilt armhf debian rootfs that you can find here: http://snapshots.linaro.org/debian/images/. these are the rootfs we are using to generate the debian image that we release eventually.

In any case you need to use the same 64 bit kernel. We do not support (and do not plan to support) 32-bit kernel for APQ8016 (the SoC on DB410c). But it is possible to run 32bit user space on 64 bit kernel.

If fact if you follow the same build scripts that we use for 64-bit images, and set the rootfs to armhf, you will end up with exactly what you need (e.g. https://git.linaro.org/ci/job/configs.git/tree/lt-qcom-debian-images-arm64.yaml).


#3

Very helpful and fast response.
I will try and update.

Thanks


#4

Which tool is used with the YAML file?


#5

it’s a Jenkins job description file. You need to ‘decipher’ it a bit and construct an equivalent Shell script. you won’t be able to use the Jenkins job as is. but really it’s not that hard. the bulk of the job is already in a shell script (search for include-raw)


#6

When using the prebuilt images. How do I convert the rootfs directory into img file so I can upload the rootfs to the dragonboard using fastboot?


#7

Following the builders.sh script, I am having trouble downloading the firmware file.
I manage to download the linux-board-support-package-v1.4.zip file, however I get MD5 mismatch error and when I try to unzip it I get the following error:

Archive: linux-board-support-package-v1.4.zip End-of-central-directory signature not found. Either this file is not a zipfile, or it constitutes one disk of a multi-part archive. In the latter case the central directory and zipfile comment will be found on the last disk(s) of this archive. unzip: cannot find zipfile directory in one of linux-board-support-package-v1.4 or linux-board-support-package-v1.4.zip, and cannot find linux-board-support-package-v1.4.ZIP, period.