Connected power but board seems always off


#1

Unfortunately it seems the DragonBoard 410c doesn’t work.

I’ve followed the quick start instructions:

  • all boot switches are set to OFF (0000)
  • connected display using HDMI cable
  • connected keyboard and mouse to USB ports
  • plugged in power supply
  • Android didn’t start and I don’t see any led blinking. Basically the board is always off and it is not possible to boot up.

My AC/DC power supply has in input 220V and output 12V 1.8A.

Do you know how could I debug directly on hardware to know if board should run or not?
Should I expect to see leds blinking after connecting the power?
Thanks in advance for your help.


#2

If, for any reason, your monitor isn’t working then I don’t think the Android build will show any signs of life (its a while since I ran it but I don’t think the user LEDs do anything with this build).

I’d recommend downloading trying out the debian release. The debian image (and its SD card based installer) will support a wider range of monitors and flash LED1 as soon as they start booting. This should make it easy for us to figure out if your board is working!

Get the image here and instructions to install it are here.


#3

Hi!

I am new working with Dragon Board 410c. I want to interface it with the pico-projector from Texas Instruments DLP Light Crafter. I suppose the pico-projector works like a display connected via HDMI, so I follow the recommended steps to connect it. But shows nothing or sometimes shows interference but never Android. Also, I can set the projector resolution and I try to make it compatible but seems to don´t work. Any help will be wonderful.

Thank you in advance,

Regards.


#4

Hi Stephany

Looking at the module’s user guide the projector supports only a very narrow range of video resolutions (Table 2-2). These will not be supported out-of-the-box by Android. To get it working you will need to build Android from source and then modify the default video timings used by the Android build. You might also have to alter things to get the ADV7533 (DSI-to-HDMI bridge) into DVI-D mode (Android currently runs it only in HDMI mode).

The “Software Build and Installation Guide, Linux Android” and “DSI Display Porting Guide, Linux Android” can both be found here.

Note that you might also like to try out the Debian build first. The Debian release already supports DVI-D and, although it has not been tested with a 608×684p60 display mode, there is a possibility that the display will work out-of-the-box with the latest projector firmware.


#5

Thank you very much Danielt, I try install Debian S.O in my Dragon Board410c and works perfect! Now I want to run apps for Android (.apk). I will try with the emmulator Genymotion and let see if I my app runs. Do you advice something else?

Thank you again.


#6

I’ve never tried an emulator but sounds like an interesting thing to try.

If that fails the resources I linked to before should allow you to modify the Android build to force it to run at the correct video resolution. However it is fiddly work which is why I suggested checking if the hardware works together using Debian first!


#7

Hi Danielt, thanks for your suggestions. I’ve tried to install Debian image on SDCard, plugged in power but Dragonboard is still dead: no leds blinking and nothing on monitor.

I start to think it is defective. Please let me know if you have any other suggestion.

Thanks a lot,
Marco


#8

It does sound like it.

The board should boot from the SD card if the DIP switches set 0-1-0-0 (i.e. switch 2 should be on) and the bootable SD card is inserted. Simply applying the power (with nothing else connected) is enough to get the LEDs flashing.


#9

Yes, I did exactly what you’ve just described. I’ll ask a replacement. Thanks