Common issues for new users


#1

The first 96Boards compatible product - the HiKey board - is available for early access now, mainly for developers at Linaro working on bringing the software up. An early access Getting Started guide is available on this site here and builds will be made available on builds.96boards.org and source will be made available on GitHub. Please use this forum to share issues you encounter as a new user.


#2

I have followed the ‘Early Access’ guide to install the revised partition table and associated files, then the Debian Jesse image. Each stage reported success.

When I attempt to boot the OS, I get:

  • No video output;
  • USB hub initialization;
  • Caps lock and Num Lock keys on keyboard start working after (say) 20 seconds;
  • USB wired network adapter initializes and gains link, but doesn’t appear to pick up an IP address;
  • Blindly typing a command sequence (verified on another HiKey system) which should light up the first on-board LED does not work

These were tried with both a uSD and EMMC image. (Note: the EA guide appears to have at least a formatting typo around the uSD dd section where the boot-fat.emmc.img flashing is described).

Testing further with the uSD image:

  • Two lines added to /etc/rc.local to (1) turn on the first user LED, and (2) place the date in a file both seem to produce no effect.

I would surmise that I’m getting a kernel that’s booting far enough to start up the USB and event subsystems but falling short of video and systemd startup (?).

Any suggestions or pointers appreciated!


#3

(Correction, when switching to uSD, I used the boot-fat.img file not boot-fat.emmc.img).


#4

Further update: it appeared that the board was booting from eMMC even with the boot-fat.img file flashed (?). Re-flashed all of the partitions, and then with some experimentation and test-driving commands on one of the test/demo machines in the LNG hacking room, I was able to blind-type the commands necessary to bring up a USB network connection and then ssh to the board.

I thought that the video on this particular card was not working, but Andrew Oatley-Willis freshly installed a card from a different system, following the Early Access guide, and found exactly the same result: the system boots but there’s no video console.

As always, any pointers or suggestions appreciated!


#5

Ran md5sum against /md5sum.txt and found no unexpected differences (i.e., differences only in files which could reasonably be expected to change).


#6

Hi,
there’s a bug in the graphics driver - it doesn’t initialize the console properly.
There’s a fairly simple workaround that’s being used on the demo machines, but I’m not sure it made it to the images on the server.

Run this:

#include <fcntl.h> #include <linux/fb.h> #include <sys/ioctl.h> #include <sys/mman.h> #include <unistd.h> #include <assert.h>

int main(int argc, char **argv) {
struct fb_fix_screeninfo fixed;
struct fb_var_screeninfo variable;
char *fb;
int line_size, size, buffer_size, i;
int fd = open("/dev/fb0", O_RDWR);
ioctl(fd, FBIOGET_VSCREENINFO, &variable);
variable.xres = 1280;
variable.yres = 720;
variable.xres_virtual = 1280;
variable.yres_virtual = 1440;
variable.bits_per_pixel = 24;
ioctl(fd, FBIOPUT_VSCREENINFO, &variable);
ioctl(fd, FBIOGET_FSCREENINFO, &fixed);
variable.xoffset = 0;
variable.yoffset = 720;
ioctl(fd, FBIOPAN_DISPLAY, &variable);
variable.xoffset = 0;
variable.yoffset = 0;
ioctl(fd, FBIOPAN_DISPLAY, &variable);
close(fd);
return 0;
}


#7

Thanks for the explanation and code.

We did something a few hours ago that solved this in a different way: We noticed that the ‘uname -a’ output from the images on the 96boards site didn’t match the ‘uname -a’ output on the demo machines at Connect – so we copied the ‘boot’ partition to a laptop and flashed the eMMC via ‘fastboot flash boot …’. This gave us working video.

The boot partition image file should probably be updated before a whole bunch of Connect attendees go home and start installing their boards :slight_smile:


#8

Another possible typo in the HiKey Users Guide pdf…

Getting Started guide says (about half way down)…
-snip-
Install the 3rd link (5-6) so that the HiKey board will enter fastboot mode when powered up (if the link is open HiKey will try to boot an OS that is not yet installed).

… but the UG identifies pins 5-6 as GPIO3_1 and pins 1-2 as AUTO PWR. Should be the other way around. right?


#9

Hi,

I have one of the Early Access Boards that were handed out at Connect in Hong Kong, but I just never had the time to spend time with it, also because I didn’t have an HDMI monitor or TV. But now I got one and I’m interested in the Hikey board again.

So I started from https://github.com/96boards/documentation/wiki/HiKeyGettingStarted#section-4, because I knew I didn’t have a preinstalled OS. I tried both the latest images and the 15.05 ones. But I just don’t get any signal on the HDMI port (or so it says). I tried my Samsung TV and a video projector. The board seems to boot ok, the user led 0 blinks twice every 6 seconds or so.

I could try and use the serial port to interact with it, but I couldn’t find much info on it, only this: https://plus.google.com/+ChrisTyler/posts/QmMfNX6FdW1. Still a way to go, but if you guys can give some more help I would appreciate it. I learned there are a couple of UART’s on the LS header as well, could I use those to get to a console and see what’s happening?

Thank you,
/Ciprian


#10

Ciprian,

I’ve been having the same video issue but have come to a work-around that fits my needs: remote SSH. I used a spare USB to 10/100 Ethernet adapter available (Cable Matters, sku 202023). Default username and password is “linaro” and “linaro”.

I’m using a purchased (post-early-access) HiKey board, and flashed with UEFI images as per Install from prebuilt binaries of https://github.com/96boards/documentation/wiki/HiKeyUEFI. Images flashed:

  • http://builds.96boards.org/snapshots/hikey/linaro/uefi/74/l-loader.bin
  • http://builds.96boards.org/snapshots/hikey/linaro/uefi/74/fip.bin
  • http://builds.96boards.org/snapshots/hikey/linaro/uefi/74/ptable-linux.img
  • http://builds.96boards.org/snapshots/hikey/linaro/debian/354/boot-fat.uefi.img.gz
  • http://builds.96boards.org/snapshots/hikey/linaro/debian/354/hikey-jessie_developer_20150929-354.emmc.img.gz
  • https://builds.96boards.org/releases/hikey/linaro/binaries/15.06/nvme.img

Respectfully,
Raccoon


#11

Hello,

I am working with an early version of the board and cannot get the hdmi port to work. I tried re-flashing it with the most recent release version of the firmware. It is still not working. It seems to boot as my usb keyboard seems to be put in a working state and the heartbeat LED is flashing. I know that my screen supports the default resolution because I have tested this resolution with a desktop computer. What should I do next?

Regards
Edgar


#12

Edgar,

I’m seeing the same thing now, previously I was suffering from a bad power source, I couldn’t even get the Num Lock led on my keyboard on, which is odd because I was able to flash the images. I tried raccoon’s indications and I was able to connect through ssh.

I haven’t had time to work on the video problem, but what I’m going to do is to try to add openssh-server to the rootfs and reflash it, then connect with ssh and see what is going on. I know that HDMI is not 100% in order on the Hikey, so maybe it’s just a matter of finding a monitor/TV that works.

I also ordered one of those serial adapters, from here: https://www.96boards.org/products/accessories/debug/ but it hasn’t arrived yet.

Cheers,
/Ciprian


#13

As I understand from comments above, early HiKey boards had an issue with HDMI output. Some users have circumvented this by using a USB to Ethernet adapter to directly SSH in. My HiKey board was purchased recently, in February of 2016; however, it seems to be experiencing similar difficulties. I attempted to flash the microSD card, but, when I tried to boot up the board, the green LEDs flashed, but there was no output on the screen, besides occasional brief flashes. Is there any record of this being fixed in subsequent releases?


#14

t.johnson: If you could, please open a bug here: https://bugs.96boards.org/enter_bug.cgi?product=HiKey

I’m very interested in sorting these hdmi issues out.


#15

Hello all,
I am trying to boot the hikey board with 4.4 kernel provided by
https://github.com/96boards/linux.git

Kernel compiliation was successful but boot process hangs at bootconsole [uart0] disable. Had anyone faced similar issues? What could be the possible problem for this ?


#16

Apologies for the late reply; from what I can remember, I’m currently trying to reflash the eMMC, which may have caused the HDMI issue. The eMMC should have been ready from the start, as I understand. My plan now is to go through the reflashing process and see if there are any hang-ups:

http://wiki.lemaker.org/HiKey(LeMaker_version):Quick_Start#Flashing_EMMC