Check your shell's language setting if you are building a kernel 4.9 image


#1

kernel 4.9 changed eMMC device from /dev/mmcblk0 to /dev/mmcblk1, but the way of latest poplar_recovery_builder.sh handling this change is not quite nice to users of different languages other than English. it uses “grep "Linux version 4.9" Image” = “Binary file Image matches” to check kernel version, and this only works on a shell with English language setting. otherwise your system booting would just stop at "Waiting for root device /dev/mmcblk0p3… "

so I think either adding a warning in instruction or adding a language setting in script is necessary.
it took me hours to notice this minor change, hope this post can save you some time.


#2

Sorry for that, Eric. Can you please confirm if adding the following line to top of the script will fix the problem?

export LC_ALL=C

Thanks.


#3

that works. thanks for your response!


#4

Just pushed the fix. Thanks.