Can't get DragonBoard 410C to boot


#1

I was able to successfully flash the DragonBoard 410C with Windows 10 IOT using Qualcomm’s Dragonboard Update Tool. After flashing it said the flashing was successful, but when I finished and reset the dip switch and tried to boot it nothing happened. There was nothing on the screen, there wasn’t even any LEDs on the Dragonboard that blinked when I rebooted it. I tried to reflash it and each time the process was the same. The Update tool said the flashing was successful, but when I reset the switch and cycled power nothing happened.


#2

Does it boot correctly if you install Debian or Android on it?


#3

I didn’t try Debian or Android, but I discovered the problem. It was the monitor. I was using a monitor for a desktop computer and I was getting a completely black screen. But when I tried plugging in a 96Boards-Display-7 LCD it worked. Well, it more or less works. It is cutting off some of the image but I am sure I just need to adjust my screen size. So I guess the resolution on my desktop monitor was not supported. I would have expected to at least see something on the screen if this was the case, but apparently not.


#4

There’s almost no support for Win10 for DB410C on this forum (we were advised to refer people to the Microsoft forum… which is a tiny bit awkward since I think they often tell people to come to ask here). Having said that there are a few community users hanging out and they sometimes offer experience.

However, regarding monitors, IIRC the Win10 graphics drivers (which come from Qualcomm rather than Microsoft) wedge the display into 1920x1080@60Hz and don’t do any integration of the display device at all. Thus whether the boards puts up an image depends entirely on whether the monitors accepts the picture (Debian has a full featured graphics stack that automatically adopts the best resolutions supported by the monitor… hence it can be useful for debugging display issues).