Can't find the /dev/video* while uvc camera device is plugin


#1

When the usb camera is plugin.

the kernel log fragment:
<6>[ 17.012775] spmi msm8x16_wcd_codec-ffffffc0329e0000: Driver wcd-spmi-core requests probe deferral
<6>[ 17.254962] usb 1-1.1: new high-speed USB device number 3 using msm_hsusb_host
<6>[ 17.436701] usb 1-1.1: New USB device found, idVendor=1908, idProduct=2310
<6>[ 17.442561] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
<6>[ 17.449924] usb 1-1.1: Product: USB2.0 PC CAMERA
<6>[ 17.454457] usb 1-1.1: Manufacturer: Generic
<6>[ 17.458724] usb 1-1.1: SerialNumber: 20100331010203
<6>[ 17.464972] uvcvideo: Found UVC 1.00 device USB2.0 PC CAMERA (1908:2310)

But, i can/t find the /dev/video??


#2
  1. are you using Android or Debian.
  2. also please provide OS version.

On the latest Debian release I do see the video node.


[  120.178530] usb 1-1.1: new high-speed USB device number 5 using msm_hsusb_host
[  120.417844] usb 1-1.1: New USB device found, idVendor=046d, idProduct=0990
[  120.417929] usb 1-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=2
[  120.423793] usb 1-1.1: SerialNumber: 89DA01E7
[  120.487002] usb 1-1.1: Warning! Unlikely big volume range (=3072), cval-&gt;res is probably wrong.
[  120.487058] usb 1-1.1: [5] FU [Mic Capture Volume] ch = 1, val = 4608/7680/1
[  120.655118] input: UVC Camera (046d:0990) as /devices/platform/soc/78d9000.ehci/usb1/1-1/1-1.1/1-1.1:1.0/input/input4
[  120.659681] usbcore: registered new interface driver uvcvideo