Cant download Header files


#1

Dear Forum

I download the prebuild image :

dragonboard-410c-sdcard-developer-buster-359.img

and copy in a sd card. Im able to boot from SD without problem, following your “guide”.

Just for be clear, the command uname -r give me:
4.14.0-qcomlt-arm64
and the command uname -a give me:

Linux linaro-developer 4.14.0-qcomlt-arm64 #1 SMP PREEMPT Fri Feb 2 21:19:01 UTC 2018 aarch64 GNU/Linux

What I would like to do is compile a module. For this I need the header files. So I tried:

sudo apt-get install linux-headers-$(uname -r)

but i get error saing:

Temporary failure resolving ‘obs.linaro.org
Unable to fetch some archive.

The same when I do the update

What can I do ?

Thanks in advance for your time
Roberto


#2

I know obs.linaro.org was down for maintainance recently so this really could have been a temporary failure! Can you try again?


#3

Thanks for your reply.

Unluky I get again a error….I will pase the command I gice and the reply…Maybe Igive wrong command:

sudo apt-get install linux-headers-$(uname -r)

-Reading package lists… Done
-Building dependency tree
-Reading state information… Done
-The following NEW packages will be installed:
*linux-headers-4.14.0-qcomlt-arm64
*0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
-Need to get 10.6 MB of archives.
-After this operation, 74.9 MB of additional disk space will be used.

-Err:1 http://obs.linaro.org/linaro-overlay-buster/buster ./ linux-headers-4.14.0-qcomlt-arm64 4.14.15-00139-g5511441d1b48-20

I must divide this message in 2 because website give me problem…Next message
show that Ive problem not only with obs.linaro…,but also deb.debian

Thanks


#4

When I try to install a evice tree compiler, this is what happend:

apt-get install device-tree-compiler

……
Err:1 http://deb.debian.org/debian buster/main arm64 device-tree-compiler arm64 1.4.5-3
Temporary failure resolving ‘deb.debian.org

Many Thanks for your time and reply

Roberto


#5

That looks like the device is not connected to the network at all (or possibly it is connected to a private network or corporate intranet and cannot see the outside world).

Can you describe how the board is connected to the internet?


#6

Thanks again for reply

Device is connect to wify…My pc also.
When,from PC i do for example

ping deb.debian.org

all is ok…pachet are ok…No lost.

The same from another board with a old version of linaro (that im not able to build because a collegue did)…

So, access outside is ok…

Rob


#7

Reading between the lines you can ping deb.debian.org from your PC and from a different board. Can you ping deb.debian.org from your DB410C?


#8

Excuse I forgot to write …No…is possible from other, but not from this board.

Consider the board are the same but:

-the workin have installed a linaro from a compilated kernel + dt (from ex collegue)
-the non working have installed the dragonboard-410c-sdcard-developer-buster-359

I have no particular passion for this version, so, if you suggest to use another I will.

My intention is to compile a module and insert it……

At same time im tring to recompile all kernel, but forn now seems for me not clear.

Thanks
Roberto


#9

Have you run apt upgrade in the broken board? There’s a bug in the 359 release that can cause many features to break if you upgrade it with putting a hold on the kernel first (basically /boot/vmlinuz and the modules in /lib/modules get updated but the special boot partition does not… this makes loading kernel modules break):

The latest snapshots come with the hold already in place to avoid problems like this in the future.

Alternatively (especially given you are doing kernel development) you might prefer to use dt-update to update the special boot partition (this will prevent version skew problems against the linux-headers you are about to install) although this can be tricky to deploy when networking is broken… because the first step in the instructions is a git pull:


#10

Yes…I run. All done, and this is the final reply:

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

The ping " deb.de bian.org" give me a Temporary failure in name resolution

Other part of your reply is not clear for me…I can say im a beginner.
Do you belive cold be more success if i concentrate on build kernel +dt myself,ad create a image ?
Im tring with “kernel-debian-qcom-dragonboard410c-18.01”…but maybe for this help I open a new post ?

Thanks

Roberto


#11

Seems my last reply is not ok for the community because seems some like spam…

So .In case you will not read, i write this:

-The problem persist
-Do you belive cold be more success if i concentrate on build kernel +dt myself,ad create a image ?
Im tring with “kernel-debian-qcom-dragonboard410c-18.01”…but maybe for this help I open a new post ?

Thanks

Roberto


#12

Regarding the spam trap that should mostly go away with time. It uses a reputation system so over time it will trust you more (and I just bumped you up a trust level so that will help too). Basically brand new users get problems with copy 'n paste because typing at super-human speeds is treated as a spam indicator :frowning: .

Personally I would recommend concentrating on building kernel+DT yourself rather the concentrate on trying to just build a kernel module. Several kernel development books contain tutorials that suggest building a kernel module for practice (especially the older ones) but I know very few people who actually develop like this; most kernel developers tend to work in the main kernel tree instead. For that reason all the 96Boards documentation is gears towards building the whole kernel at once:

If you have nothing valuable on your DB410C I would also recommend reinstalling is the simplest way to get network running again and that you put a hold on the kernel package before attempting an apt upgrade. It is important to be able to upgrade with confidence so making this change is a good idea. You can put a hold on the kernel package like this:

sudo apt-mark hold linux-image-4.14.0-qcomlt-arm64

PS There is no need to reinstall. If you have valuable files on your DB410C then we can get networking working again if you prefer… but there are guides on how to reinstall so it is a better documented route (and I’m slightly lazy so I prefer to send people on documented routes if possible… we both make fewer mistakes that way :wink: ).


#13

Thanks very much for your reply Mr Danielt.

I will try to rebuild all as you suggest.

Thanks also for my upgrade.

Roberto