Can't connect as USB-Ethernet on Windows 10

Heya,

I’ve been painfully trying to connect the board via USB-type B port on the board to my computer via USB-type A male to USB-type B port. it’s been unsuccessful so far.

I’ve been using the default OS which ships with Ultra96.

I have also tried multiple computers all running Windows 10 - 3 laptops and 1 desktop. None could detect it.

Is there any OS build which works better?

I heard about RNDIS as well, it should show up in Device manager. Didn’t show up for me :frowning:

I have a Mac as well and would love to get it working on it, but don’t know how.

Any help on the above questions / pointers for further reading highly appreciated.

thanks :slight_smile:

Hello,

Access to the UART on the Ultra96 is via the low-speed mezzanine connector, and that requires purchasing an adapter board. If command-line access to the Ultra96 is desired it may be best to connect the Ultra96 to your Wi-Fi LAN and use
a ssh command shell. This is described in the Ultra96 Getting Started Guide (http://zedboard.org/sites/default/files/documentations/Ultra96-GSG-v1_0.pdf ). You should
also be able to use a USB-to-Ethernet adapter (for example
https://www.trendnet.com/products/product-detail?prod=285_TU2-ET100
) if Wi-Fi is not desired.

–Tom

Hi Tom,

Thank you so much for your response. It was something which I didn’t think of. Using USB-A is a great idea. I was stuck on USB-B / micro-USB till now.

I tried the USB-to-Ethernet adapter I have from Apple on the board and I did end up having the board recognized as an ethernet connection. Sadly couldn’t actually connect to it, as it seems it couldn’t assign / find an IP address.

And the reason I kept on plugging in the micro-USB port and expecting internet is because I was following: https://ultra96-pynq.readthedocs.io/en/latest/getting_started.html

  1. Insert the Micro-SD card
    2. Connect the Mirco USB cable from your PC to the board
  2. Connect the power supply to the board
  3. Press the SW3 power button to power on the board

I’ll now follow along with the Wi-Fi approach. Though the docs and other online places still recommend the USB / Ethernet approach.

The