Can not hide the mouse cursor on interface! -Debian-


#1

Hello everyone,

I am working on a Debian-based Dragon Board (410C) system. That is a free-lancer/student project that I am developing on my car actually. The system will produce a touch screen that triggers some functions of a car. I am trying to hide the mouse cursor in my application. I tried such of ways to hide the cursor as installing application ‘unclutter’ and running it at startup file (.myxinitrc) with the command ‘unclutter -idle 0.1 -root’ and ended up with a working command, but no visual changes at all, but when I try the command on an another Debian-based Ubuntu system, set the command to run at the startup, it hides the cursor as I want. I also tried to write option ‘.myxinitrc – -nocursor’ when I am calling my xinitrc file at the startup.

I think that maybe a graphical mouse cursor image (not an actual cursor) by the interface may cause the fail.

Please let me know what can I do about it.


#2

Install unclutter with apt and edit the config file (/etc/default/unclutter).

START_UNCLUTTER="true"
EXTRA_OPTS="-idle 0 -display :0"

#3

Tank you for your reply!

When I change the config file as you say, it changes nothing :frowning:

And I noticed that, when I enter the command
unclutter -idle 0 -root
it gives an error like “unclutter could not open display”. If I change the command like
unclutter -idle 0 -root -display :0
it runs the command (it moves to the next line and idles until I press ^c) but still nothing changes. When I run the same command on my Ubuntu, it hides the cursor.

Btw, system runs my service called “mycarui” at startup. Not a linux interface or anything. It has only guided access to my service as default. Maybe it can help on the solution.


#4

Have you tried the nocursor option:
https://www.x.org/wiki/AdvancedTopicsFAQ/#index1h2